Help us understand the problem. What is going on with this article?

Swift 2.0 で MaterialKit を使用する方法

More than 3 years have passed since last update.

以下の記事で紹介されているMaterialKitというライブラリがよさげだったので、
使ってみることに
iOSの開発でお気に入りのライブラリN選

MaterialKit

インストール

ReadMeを見ていたらCocoapodsで入れれるみたいなので、
Podfileを書く

Podfile
platform :ios, "8.0"
use_frameworks!

pod 'MaterialKit'

そしてpod install してビルドしてみると・・・・大量のエラーが。

スクリーンショット 2015-12-27 21.02.03.png

どうやらSwift 2.0 で使う場合には :head を指定してあげないとだめみたいです
(参考:https://github.com/nghialv/MaterialKit/issues/45)
まだSwift 2.0 対応版がリリースされてないのかな

Podfileを以下のように修正し、再インストール

Podfile
platform :ios, "8.0"
use_frameworks!

pod 'MaterialKit', :head

エラーもでなくなり、綺麗にビルドできました〜

感想

Carthage に対応してくれないかな〜とか思ったり。
PRは出てましたけどね

tamanugi
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away