【備忘録】brew/rbenv/bundler/gem 環境構築

  • 2
    Like
  • 0
    Comment

参考

rbenv を利用した Ruby 環境の構築
Rails開発環境の構築(rbenvでRuby導入からBundler、Rails導入まで)(Macport編)
MacにHomeBrew,rbenv,bundlerをインストールする
Ruby on Rails 5.0 インストール手順書 (OIAX BOOKS)

rbenv

ruby-buildプラグインの更新

最新バージョンのrubyをダウンロードするために必要

cd ~/.rbenv/plugins/ruby-build
git pull
最新のリストを取得
rbenv install --list

バージョン切り替え

rbenv versions
* system (set by /Users/mochizuki-kazuki/.rbenv/version)
  2.3.3

以下の順で強くなる
shell > local > global

強い
rbenv shell 2.3.3
弱い
rbenv global 2.3.3  # 切り替え
rbenv global system # 元に戻る

gem

キーワードから探す
https://rubygems.org/

カテゴリーから探す
https://www.ruby-toolbox.com/categories/by_name

エラー

brew updateできないエラー

Error: /usr/local is not writable. You should change the ownership
and permissions of /usr/local back to your user account:
  sudo chown -R $(whoami) /usr/local

素人がEl Capitanにアップデートしてみたやつ。

zshを使っていて、shoptでエラー

shoptはbashの内蔵コマンドなのでzshで使えない
zshをインストールするとshoptが使えない

いったんbashに戻してすすめる
ログインシェルをbashからzshに変更してみた。

Xcode Mac OS X 10.12用でエラー

BUILD FAILED (OS X 10.11.6 using ruby-build 20160602)

Inspect or clean up the working tree at /var/folders/xl/rk7lc6ld0z504vw9kjdnb13w0000gp/T/ruby-build.20161027122650.14471

Last 10 log lines:
  Referenced from: /private/var/folders/xl/rk7lc6ld0z504vw9kjdnb13w0000gp/T/ruby-build.20161027122650.14471/ruby-2.3.0/./miniruby (which was built for Mac OS X 10.12)
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _clock_gettime
  Referenced from: /private/var/folders/xl/rk7lc6ld0z504vw9kjdnb13w0000gp/T/ruby-build.20161027122650.14471/ruby-2.3.0/./miniruby (which was built for Mac OS X 10.12)
  Expected in: /usr/lib/libSystem.B.dylib

Xcode8環境下でrbenvにてrubyのコンパイルに失敗する

rubyのバージョン違い

バージョン違いのエラー
Your Ruby version is 2.0.0, but your Gemfile specified 2.3.1

↑こんな感じのエラーが出たらshellかlocalでバージョンを切り替える

それがダメならwhich rubyを確認。
/usr/bin/rubyと出たら、systemのrubyを使っているのでパスを変える

~/.zshrcに追加
eval "$(rbenv init -)"

参考
rbenv利用時にruby -vで古いバージョンのRubyが呼ばれる場合の対処

おまけ

rmagickのインストールエラー

rmagickのインストールでMagick-config...noとoutdated ImageMagick version (<= 6.4.9)と言われたので解決する