Edited at

Visual Studio Codeが1.15版で認証プロキシに対応していた

More than 1 year has passed since last update.

メモ。使い始めたころにはいつも通り認証プロキシを超えるのに四苦八苦していたけど、以下のバージョンでプロキシ認証に対応していた。

プルリクエストを見ると、以下のバージョンでも関連修正が入っているみたい。

VSCodeを1.14版から最新の1.24.1版に更新したら、次のような認証ダイアログが出て、認証プロキシ経由で簡単に拡張をインストールできた。プロキシサーバーの情報は、システム設定(WindowsであればIEやEdgeの設定)から自動取得されている。

現在のドキュメントにはこうした形でのプロキシサポートが説明されているけど、使用しているバージョンがギリギリ古いことで動作しなくて、軽く悩んだ。これからの利用者ではまる人はいないはずだけど、去年の2017年6月より前にVSCodeをインストールしてまだ認証プロキシで消耗している人がいたら、VSCodeを更新するとよいです。