Help us understand the problem. What is going on with this article?

rails install で詰まった話

結論この記事を参考にしたら解決

https://qiita.com/amuyikam/items/313bc89c1de320a4257e

こんなエラーが

➜  ~ gem install rails
ERROR:  Error installing rails:
    zeitwerk requires Ruby version >= 2.4.4.

rubyのバージョンが古かった。

  ~ ruby -v
ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-darwin18]

この記事を参考にrubyのバージョンを 2.4以上にする

https://qiita.com/TAByasu/items/47c6cfbeeafad39eda07

ダメか

➜  ~ rails new sample
Rails is not currently installed on this system. To get the latest version, simply type:

    $ sudo gem install rails

You can then rerun your "rails" command.
# これで解決
hash -r
➜  ~ rails _5.2.2.1_ new sample
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
Comments
No comments
Sign up for free and join this conversation.
If you already have a Qiita account
Why do not you register as a user and use Qiita more conveniently?
You need to log in to use this function. Qiita can be used more conveniently after logging in.
You seem to be reading articles frequently this month. Qiita can be used more conveniently after logging in.
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
ユーザーは見つかりませんでした