dkms prblem Install CUDA toolkit8

  • 0
    Like
  • 0
    Comment

    CUDA toolkit8をインストール

    https://developer.nvidia.com/cuda-toolkit より
    CUDA toolkit8をCentOS7にインストールする。
    Linux > x86_64 > RHEL > 7 > rpm(local) を選択し、rpmをダウンロードする。
    サイトにしたがって、
    Installation Instructions:
    sudo rpm -i cuda-repo-rhel7-8-0-local-ga2-8.0.61-1.x86_64.rpm
    sudo yum clean all
    sudo yum install cuda
    を実行したところ。。。

    エラー: パッケージ: 1:nvidia-kmod-375.26-2.el7.x86_64 (cuda-8-0-local-ga2)'
    要求: dkms
    問題を回避するために --skip-broken を用いることができます。

    エラーのためインストール出来ず。

    dkms をインストール

    https://devtalk.nvidia.com/default/topic/983078/dkms-problem-while-installing-cuda-8-on-rhel-7-3-ppc64le/?offset=3
    より
    yum install epel-release のあと
    yum install dkmsを実行する。
    これで
    yum install cudaを実行するとちゃんとインストールされる。
    nvcc -V で確認。

    nvcc: NVIDIA (R) Cuda compiler driver
    Copyright (c) 2005-2016 NVIDIA Corporation
    Built on Tue_Jan_10_13:22:03_CST_2017
    Cuda compilation tools, release 8.0, V8.0.61
    と出ればOK。