Git

gitで"error: There was a problem with the editor 'vi'."

More than 1 year has passed since last update.

タイトルのエラーになったとき、エディタを設定することで解決する。

例えばエディタをvimに設定するには

git config --global core.editor vim

設定の確認は

less ~/.gitconfig

[core]

editor = vim