Posted at

Run/Debug Configurations で Please select Android SDK エラー

More than 3 years have passed since last update.

IntelliJをバージョンアップしてRun/Debugを実行すると"please select Android SDK"のエラーが起きるようになりました。テストやビルドではエラーにならずapkパッケージの作成時にエラーになります。

スクリーンショット 2014-10-19 14.50.43.png

参考までに問題が発生した環境は以下の通り。この環境だけの問題ではなく他のバージョンでも発生すると思われますのであくまで参考までに。Android Studioでも発生するようです。


  • Mac OS X

  • IntelliJ IDEA 13.1.5

  • Android Gradle Plugin 0.13.2


調べてみると事例がいくつか上がっているようです。

https://code.google.com/p/android/issues/detail?id=73086

http://stackoverflow.com/questions/21070268/intellij-idea-13-error-please-select-android-sdk

Project Structureを開いてSDKsを設定し直し

スクリーンショット 2014-10-19 14.27.36.png

Modulesを設定し直し

スクリーンショット 2014-10-19 14.28.27.png

これでエラーは消えました。