Posted at

git rebase -i で “Could not execute editor”

More than 3 years have passed since last update.

gitに設定されているvimのパスがよろしくないらしい。

以下のコマンドで解決した。

% which vim                                                                                                                                                                                                                    (git)-[topic-help-#21]

/usr/local/bin/vim
% git config --global core.editor "/usr/local/bin/vim"

参考:http://blog.44uk.net/2011/09/26/could-not-execute-editor-while-using-git/