Ruby
Rails
bundler
IntelliJ
IntelliJIdea

Intellij IDEAでRailsプロジェクトのbundleができない


環境


  • IntelliJ IDEA 2018.2.5 (Ultimate Edition)

  • macOS 10.14.1

  • Ruby 2.2.2

これらを使ってSDKとBundlerのパスは設定済み

https://www.task-notes.com/entry/20160508/1462676400

https://qiita.com/keitakn/items/76d6707db7d23fe4ca85

https://qiita.com/sunny4381/items/b9317d73b98eb1470140


原因

Ruby 2.4系からBundlerがdefaultのgemになったことによるRubyMineのバグらしい。。

https://intellij-support.jetbrains.com/hc/en-us/community/posts/360000609684-Cannot-find-bundler?page=1#community_comment_360000235919


追記

JRubyと認識されてたからだった。

https://www.task-notes.com/entry/20160508/1462676400

の「プロジェクトの作成パターン」の通りやればそのままできた。作成画面が微妙に違ってるので、自分の場合はこうだった。

Screen Shot 2018-11-12 at 23.06.02.png