Help us understand the problem. What is going on with this article?

AzureのAppServiceのリモートデバッグ起動時にエラー

More than 1 year has passed since last update.

VS2017のサーバーエクスプローラーから、AzureにデプロイしているAppServiceを選択。「デバッガーのアタッチ」を選択してしばらく待つと次のようなエラーが発生。

image.png

文面からするとApp Service が32ビットのプロセスになっているかと思い、AzureのPortalで設定をチェック。
設定は64Bitになってる。

image.png

しばらく考えてみてよくわからないので、App Serviceのプラットフォームを32Bitに変更して再度サービスを起動。その後、再度プロセスにアタッチしてみると、今度はうまくいってリモートデバッグも無事できた。

サービスを32Bitにすることで、リモートデバッガーも自動的に32Bitが起動したのだろうか?

giants55_515
野球と酒が好きなおっさんです。
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
Comments
No comments
Sign up for free and join this conversation.
If you already have a Qiita account
Why do not you register as a user and use Qiita more conveniently?
You need to log in to use this function. Qiita can be used more conveniently after logging in.
You seem to be reading articles frequently this month. Qiita can be used more conveniently after logging in.
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
ユーザーは見つかりませんでした