Xcode
iOS
CocoaPods
Swift
playground

Swift PlaygroundでCocoaPodsのライブラリを使う

More than 3 years have passed since last update.

※Xcode 6.2


xcworkspaceをつくる

pod installしてあれば出来ています。

Swiftが含まれているPodを使う場合はPodfileにuse_frameworks!が必須になっています。

まだ変えていない場合はpod installしなおします。(deployment targetがiOS 8以上の必要があります)


xcworkspaceにPlaygroundファイルを追加する

File -> New -> File... -> Playground で


playgroundファイルにimportを追加

PodfileでインストールしたPodの名前でimport

import AsakusaSatellite

このままだとフレームワークが見つからないエラーが出ています。


Podのframeworkをビルドする

デフォルトではPodのframeworkのスキームは見えていません。

Scheme -> Manage Schemes...

で,Pods-AsakusaSatellite のShowをチェックします。

Screen Shot 2015-03-19 at 21.40.26.png

追加したスキームの64bitシミュレータを選択してビルドします。(iPhone 6など)

これでPlaygroundでimportのエラーがなくなります。


Play!

Screen Shot 2015-03-19 at 21.06.45.png


See Also