Help us understand the problem. What is going on with this article?

vue-validatorの対応バージョンメモ

More than 3 years have passed since last update.

対応表(2016/01/28調べ)

Vue.js vue-validator
0.x 1.x
~1.0.13 動作するバージョンなし?
1.0.14~ 2.0.0-alpha.x

※詳細は未検証です。

最新バージョン(2016/01/28時点)

Vue.js vue-validator
1.0.15 2.0.0-alpha.16

インストール

 2016/01/28時点でvue-validatornpm install vue-validator するとインストールされるバージョンは 1.4.4 です。

package.json
"dependencies": {
  "vue-validator": "^1.4.4"
}

しかし、

vue-valudator 1.x is not working with VueJS 1.x. Use vue-validator 2.x.

らしい1ので、 2.x系のvue-validatorをインストールします。

$ npm install vue-validator@^2.0.0-alpha --save
とか
$ npm install vue-validator@2.0.0-alpha.16 --save
とか

もしくは

package.json
"dependencies": {
  "vue-validator": "^2.0.0-alpha"
}

と書いて、

$ npm install

 ただし、逆にvue-validator 2.x(というか2.0.0-alpha.16の時点で)は Vue.jsの1.0.14+が必須2なので、1.0.14未満を使用している場合は、1.0.14以上にアップデートしましょう。

[参考] 依存関係不整合時のエラー例

vue@1.0.12vue-validator@2.0.0-alpha.16 だと

Uncaught TypeError: Cannot read property 'push' of undefined

vue@1.0.12vue-validator@1.4.4 だと

Uncaught TypeError: Vue.parsers.directive.parse is not a function 
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away