MySQL

This gem was compiled for 5.5.29 but the client library is 5.6.1

More than 3 years have passed since last update.

http://cacaosoft.web.fc2.com/tkool/lecture/rgss2/015.html

エラー

Fixing "Incorrect MySQL client library version! This gem was compiled for 5.5.29 but the client library is 5.6.10. (RuntimeError)" on OS X while using Brew


解決


sudo ARCHFLAGS="-arch x86_64" gem install mysql2 -- –with-mysql-config=/usr/local/bin/mysql_config