Posted at

Unity5.3.2でVuforiaが使えなかった話

More than 3 years have passed since last update.


はじめに

UnityでVuforiaを使ってLive2DとARの可能性を感じるでコメントしましたが、Unity5.3.2p1で開発をしていたところ、エラーが出てつまづきました。


Unity5.3.2でVuforiaが使えなかった

Unity5.3.2p1で開発中、ARの導入にVuforiaを使おうと、

VuforiaのSDKをインポートして、マーカーをインポートして・・・としていたところ、ImageTarget を Hierarchy に追加したところ、下記画像のようなエラーが出て、Unityが落ちました。

unityerror.png

原因はこちらでした。

NOTICE:Unity 5.3.2 incompatible with Vufoia

どうやらVuforiaではUnity5.3.2、5.3.1p4 をサポートしていないそうです。

Unity5.3.1f1 もしくは 5.3.1p3 を使うように、とのことです。