ネットワーク
vlan
Cisco
ルーティング

CiscoのRouterとSwitch1台とPC2台を使ってVlan間ルーティング

1:ネットワーク構成図

構成図.png

2:用意する機材等

・ルーター1台
・スイッチ1台
・LANケーブル4本
・コンソールケーブル1本
・PC2台(win機)

3:RouterとSwitchの初期化

既存の設定を初期化
enableで特権モード
erase startup-configでNVRAM上のコンフィグを削除
reloadで再起動する

4:Routerの設定

vlan10にinterface g0/0を設定

ログイン後にまずはenableで特権モード
configure terminalでグローバルコンフィグレーションモード
int vlan 10でvlan10を作成
exitしてからvlan10にg0/0を設定する
interface g0/0にしてswitch mode accessして
switch access vlan 10で設定する
no shutdownで有効化
exitで戻る

vlan20にinterface g0/1を設定

ログイン後にまずはenableで特権モード
configure terminalでグローバルコンフィグレーションモード
int vlan 20でvlan20を作成
exitしてからvlan20にg0/1を設定する
interface g0/1にしてswitch mode accessして
switch access vlan 20で設定する
no shutdownで有効化
exitで戻る

vlan10にipアドレス設定

configure terminalでグローバルコンフィグレーションモードへ
interface vlan 10でvlan10の設定
ip address 192.168.1.254 255.255.255.0でipの設定
no shutdownで有効化
exitで戻る

vlan20にipアドレスの設定

configure terminalでグローバルコンフィグレーションモードへ
interface vlan 20でvlan10の設定
ip address 192.168.2.254 255.255.255.0でipの設定
no shutdownで有効化
exitで戻る

5:Switchの設定

vlan10にinterface f0/1とf0/2を設定

ログイン後にまずはenableで特権モード
configure terminalでグローバルコンフィグレーションモード
int vlan 10でvlan10を作成
exitしてからvlan10にf0/0を設定する
interface f0/1にしてswitch mode accessして
switch access vlan 10で設定する
no shutdownで有効化
exitで戻る

interface f0/2にしてswitch mode accessして
switch access vlan 10で設定する
no shutdownで有効化
exitで戻る

saveしてwrite memoryして設定を保存する

vlan20にinterface f0/3とf0/4を設定

ログイン後にまずはenableで特権モード
configure terminalでグローバルコンフィグレーションモード
int vlan 20でvlan20を作成
exitしてからvlan20にf0/3を設定する
interface f0/3にしてswitch mode accessして
switch access vlan 20で設定する
no shutdownで有効化
exitで戻る

interface f0/4にしてswitch mode accessして
switch access vlan 20で設定する
no shutdownで有効化
exitで戻る

saveしてwrite memoryして設定を保存する

vlan10にipアドレスの設定

configure terminalでグローバルコンフィグレーションへ
interface vlan 10でvlan10の設定
ip address 192.168.1.253 255.255.255.0でipの設定
no shutdownで有効化
exitで戻る

vlan20にipアドレスの設定

configure terminalでグローバルコンフィグレーションへ
interface vlan 20でvlan20の設定
ip address 192.168.2.253 255.255.255.0でipの設定
no shutdownで有効化
exitで戻る

6:pingで疎通確認

win機を2台用意してから、機内モードにし、win機のコントロールパネルからそれぞれに固定ipを割り振る
pcAに192.168.1.5
pcBに192.168.2.5
を振る

ここで疎通を通すのに一番重要なことがwin機はファイアフォールがONになっていると疎通が通らないので、
コントロールパネルからファイアフォールを全てOFFにする。
疎通確認が終わったら必ずONに戻すこと!!!
pcAでコマンドプロンプトを開き、ping 192.168.2.5をして、疎通できていることがわかる