はじめに
管理者監視ワークスペースのモデル更新が止まっていたことがわかった。
Purview Hub は OneLake Catalog の Governance for Admin タブ に移行しています。その他のレポートも基本的にはそのような傾向にあるようなので、OneLake Catalog Governance for Admin の使い方は抑えておく必要があります。
https://learn.microsoft.com/ja-jp/fabric/fundamentals/whats-new-archive
確認
Fabric 管理者ロールのユーザーで以下実行
from sempy import fabric
client = fabric.FabricRestClient()
url = f"v1/admin/workspaces/{workspace_id}"
result = client.delete(path_or_url = url)
result
ワークスペースにアクセスするとモデルがすべて削除され、ロードが始まる
復旧した
インストール直後なのでデータはまず消えた状態になる
最初にアクセスするユーザーは、Fabric 管理者ロールを直接割り当てられているユーザーにしてください。
冒頭リンクに記載の通り、Admin monitoring workspace は、Fabric 管理者が初めてアクセスした際に自動的に作成され、そのユーザーの資格情報を使用してセマンティック モデルの定期更新が構成されます。
最初にアクセスしたユーザーが Fabric 管理者でなくなった場合、または PIM を利用していて定期更新時に管理者ロールが有効化されていない場合、データ更新が失敗する可能性があります。
また、管理者ロールがグループ経由で付与されているユーザーが初期セットアップを行った場合も、データ更新が失敗します。
数分後初回更新が開始する
更新後、データも直近30日間で再取得される
以上、参考になれば幸いです。







