Posted at

rbenv を利用している際に Pow が rbenv の ruby を使ってくれない場合の対処法

More than 5 years have passed since last update.

Pow や Powder はとても便利なのですが、インストールした際に rbenv の ruby ではなく、OSX に付属の ruby が使われてしまう場合の対処法です。


問題が発生した環境

OSX 10.8

rbenv 0.4.0

pow 0.4.0


症状

rbenv で ruby を導入していて、global や local で ruby のバージョンを指定しているにもかかわらず、pow が OSX 付属の ruby(/System/Library/Frameworks/Ruby.framework/) を使ってしまう。


解決方法

~/.powconfig で rbenv の shims や bin に path を通す。


設定例

export PATH=$(rbenv root)/shims:$(rbenv root)/bin:$PATH


参考情報

rbenv does not work well with pow