はじめに
自己学習の検証時にプロキシサーバーが必要になったのですが、今まで構築したことがなかったため、実際に構築した手順をまとめます。
Squidとは
HTTP、HTTPS、FTP プロトコルのプロキシーとして機能し、アクセス認証と制限を可能にするキャッシングプロキシーサーバーです。
アクセス認証として、LDAPやKerberos認証を利用することもできます。
構築手順
RHEL10で実施していきます。
# cat /etc/redhat-release
Red Hat Enterprise Linux release 10.2 (Coughlan)
squidではキャッシュの設定なども行えますが、今回はアクセス制御に焦点を当てて構築していきます。
導入
インストールは dnf を使用して行います。
squid は AppStream のリポジトリに含まれているため、通常リポジトリの設定は必要ありません。
# dnf install squid
完了したら、squid -vコマンドでインストールの確認を行います。
# squid -v
Squid Cache: Version 6.10
Service Name: squid
...
設定ファイル変更
以下のファイルを編集することで、squidの設定を変更することができます
/etc/squid/squid.conf
aclとhttp_accessで、アクセス制御を行うことが可能です。
- acl:接続元のIPアドレスや接続先ポート番号などの条件を定義
- http_access:aclに対してアクセスの許可・拒否を定義 ※上に記載されたものが優先
例)プライベートIPからの接続かつ接続先ポートが80/21/443のもののみ許可
acl localnet src 10.0.0.0/8 # RFC 1918 local private network (LAN)
acl localnet src 172.16.0.0/12 # RFC 1918 local private network (LAN)
acl localnet src 192.168.0.0/16 # RFC 1918 local private network (LAN)
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
http_access deny !Safe_ports
http_access allow localnet
http_access deny all
外部ファイルからパラメータを読み込むこともサポートしているため、以下のようにドメインの許可リストを定義することも可能です。
acl localnet src 10.0.0.0/8 # RFC 1918 local private network (LAN)
acl localnet src 172.16.0.0/12 # RFC 1918 local private network (LAN)
acl localnet src 192.168.0.0/16 # RFC 1918 local private network (LAN)
acl allowlist dstdomain "/etc/squid/allowlist.txt"
http_access allow localnet allowlist
http_access deny all
allowlist.txt には許可するドメインを定義します。
.example.com
.example.net
他にもlistenするポートやキャッシュの設定などもできますが、アクセス制御のみの説明とするため割愛します。
今回は以下のような設定ファイルとしました。
ほぼデフォルトの定義を使用し、ドメインの許可リストの設定を加えた形になります。
#
# Recommended minimum configuration:
#
# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed
acl localnet src 0.0.0.1-0.255.255.255 # RFC 1122 "this" network (LAN)
acl localnet src 10.0.0.0/8 # RFC 1918 local private network (LAN)
acl localnet src 100.64.0.0/10 # RFC 6598 shared address space (CGN)
acl localnet src 169.254.0.0/16 # RFC 3927 link-local (directly plugged) machines
acl localnet src 172.16.0.0/12 # RFC 1918 local private network (LAN)
acl localnet src 192.168.0.0/16 # RFC 1918 local private network (LAN)
acl localnet src fc00::/7 # RFC 4193 local private network range
acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines
acl SSL_ports port 443
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl allowlist dstdomain "/etc/squid/allowlist.txt"
#
# Recommended minimum Access Permission configuration:
#
# Deny requests to certain unsafe ports
http_access deny !Safe_ports
# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports
# Only allow cachemgr access from localhost
http_access allow localhost manager
http_access deny manager
# This default configuration only allows localhost requests because a more
# permissive Squid installation could introduce new attack vectors into the
# network by proxying external TCP connections to unprotected services.
http_access allow localhost
# The two deny rules below are unnecessary in this default configuration
# because they are followed by a "deny all" rule. However, they may become
# critically important when you start allowing external requests below them.
# Protect web applications running on the same server as Squid. They often
# assume that only local users can access them at "localhost" ports.
http_access deny to_localhost
# Protect cloud servers that provide local users with sensitive info about
# their server via certain well-known link-local (a.k.a. APIPA) addresses.
http_access deny to_linklocal
#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#
# For example, to allow access from your local networks, you may uncomment the
# following rule (and/or add rules that match your definition of "local"):
http_access allow localnet allowlist
# And finally deny all other access to this proxy
http_access deny all
# Squid normally listens to port 3128
http_port 3128
# Uncomment and adjust the following to add a disk cache directory.
#cache_dir ufs /var/spool/squid 100 16 256
# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid
#
# Add any of your own refresh_pattern entries above these.
#
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
refresh_pattern . 0 20% 4320
.google.com
.gstatic.com
.microsoft.com
設定ファイル変更後はサービスを再起動します。
# systemctl restart squid
# systemctl status squid
動作確認
Windowsのクライアントで動作確認を行っていきます。
プロキシ設定前はgoogle.comへのアクセスができない状態です。

次にプロキシサーバーの設定を行います。
アドレス/ポートにはsquidをセットアップしたサーバーを入力します。

設定後に再度確認すると、アクセスができるようになっています。

また、allowlist.txtに記載したドメイン以外にはアクセスできないことも確認できます。

最後に
今回はプロキシサーバーの構築を実施しました。
必要最低限の設定であればそこまで難しくなく行えることがわかりました。