Help us understand the problem. What is going on with this article?

npm intallしたときに脆弱性チェックでエラーが発生した

More than 1 year has passed since last update.

npm intallしたときに脆弱性チェックでエラーが発生した

❯ npm install
audited 28991 packages in 10.578s
found 7 vulnerabilities (1 low, 1 moderate, 4 high, 1 critical)
  run `npm audit fix` to fix them, or `npm audit` for details

npm auditで詳細をチェックできる。

下記のように表示されるので、# Run以下のコマンドを実行して脆弱性に関わる問題を解消する。
image.png

0になった。

❯  npm install --save-dev nightwatch@1.0.11
npm WARN url-loader@1.1.1 requires a peer of webpack@^4.0.0 but none is installed. You must install peer dependencies yourself.

+ nightwatch@1.0.11
added 18 packages from 440 contributors, removed 22 packages, updated 16 packages and audited 28985 packages in 12.468s
found 0 vulnerabilities

脆弱性の警告を受けたnpmパッケージの依存関係を力技で直す

okaokaokaokatoru
Ruby, Ruby on Rails, React, Swift
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away