search
LoginSignup
193

More than 5 years have passed since last update.

posted at

npm自体のバージョンを上げる

npm installを実行しようとしたら怒られました。

最近 gulp-imageminを利用しようとして、npm installを実行しようとしたら怒られました。

npm i --save-dev gulp-imagemin                                                                                                                            
npm WARN engine imagemin@3.0.0: wanted: {"node":">=0.10.0","npm":">=2.1.5"} (current: {"node":"0.10.33","npm":"1.4.28"})

お前のnpmは古い!と言われている感じですね。

npm自体のアップデートをする必要があるみたい

まずは確認しましょう。

$ npm --version                                                                                                                                             
1.4.28

あげてみます。 npm install -g npmって不思議な感じしますね。npmでnpm自身をアップデート出来るんですね笑

$ npm install -g npm                                                                                                                                             

再度確認しました。 2.1.8にあがってますね。

$ npm --version                                                                                                                                             
2.1.8

ひとりごと

それにしても、npmのアップデートってググラビティが良く無いですね。
npm updateの使い方とかが検索されてしまうので汗

npm自身、npm自体...みんな何て検索するんだろう。

Register as a new user and use Qiita more conveniently

  1. You get articles that match your needs
  2. You can efficiently read back useful information
What you can do with signing up
193