Ubuntuでknife-soloをインストールするときにエラー

  • 15
    Like
  • 0
    Comment
More than 1 year has passed since last update.

ubuntuでknife-soloをインストールしようとして下記のエラーが出てしまいました。

Building native extensions.  This could take a while...
ERROR:  Error installing knife-solo:
    ERROR: Failed to build gem native extension.

/usr/bin/ruby2.1 extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

extconf failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.1.0/gems/libyajl2-1.1.0 for inspection.
Results logged to /var/lib/gems/2.1.0/extensions/x86-linux/2.1.0/libyajl2-1.1.0/gem_make.out

下記を実行で解決
sudo apt-get install ruby2.1-dev

ネット上で sudo apt-get install ruby-dev とすれば解決と書いてあったが、実行してもruby-dev は既に最新バージョンですと出るのみ。
もっと調べたところ ruby2.1-dev も必要だったようです。

ちなみにこれでbundleのエラーも出なくなりました。