Xcode
iOS
CocoaPods

【エラー】Cannot load module 'hogehoge' as 'hogehoge'

More than 1 year has passed since last update.

ライブラリと同じ名前のプロジェクトを間違えて作っちゃったのが原因。

以下にキャッシュが残ってるので、そっちをみちゃってた。
ゴミを削除して解決。
~/Library/Developer/Xcode/DerivedData/