Posted at

Sencha JetBrains Plugin のライセンス認証ができないのを解消する

JetBrains IDE をアップグレードしたら、ライセンス認証が効かなくなってしまうという状態を解消する方法です。


対象バージョン


  • PHPStorm 2019.2, PyCharm 2019.2 など、JetBrains IDE 全般

  • Sencha JetBrains Plugin 6.0.12

  • 動作環境: macOS Mojave


    • macOS でしか起こってないかもしれない...




現象


  • 2019.2 に上げたとたんに、

  • 起動時にライセンス認証ダイアログが表示されるようになる

  • ダイアログにどれだけ正しい情報を入れてもライセンス認証ができなくなる


対策


  • Sencha Support に問い合わせたが、現在対策中という答えのまま、まだ対策は出ていない。

  • Sencha Forum でのディスカッションの中に JVM 8 を使ってみたら? というコメントを見つけたので、JDK8 に切り替えてみると見事に解消した。


JDK8 への切り替え方

以前に PyCharm でフォントがちらつくようになったときに、JDK を切り替える方法を調べたので、そちらを参照してください。

こちらです。Pycharm 2019.1 でフォントがちらつくのをなんとかする

MacOS で JDK11 の場合、なんかいろいろと不具合満載のようなので、JDK8 で良くなることも多いみたいです。