Subversion

Subversionを使用する際に cannot set LC_CTYPE locale と警告が出る場合

More than 5 years have passed since last update.

問題の概要

Subversionを使用する際に cannot set LC_CTYPE locale と警告が出ることがある。

$ svn update
svn: warning: cannot set LC_CTYPE locale
svn: warning: environment variable LANG is ja_JP.UTF-8
svn: warning: please check that your locale name is correct

これは使用している環境に環境変数LANGで指定しているロケールが存在しないため発生する。

対処法

環境変数LANGに正しいロケールを指定する。(例は en_US.UTF-8 を指定した場合)

$ export LANG=en_US.UTF-8
$ svn update
At revision 4584.