CentOS

CentOS 6.4 で/boot 以下を整理する

More than 5 years have passed since last update.


yum upgrade でエラー

CentOS 6.4 で yum upgrade したら下のエラーが・・・

upgrade のたびに古いkernel がたまって /boot がいっぱいらしい

Transaction Check Error:

installing package kernel-2.6.32-358.23.2.el6.x86_64 needs 4MB on the /boot filesystem

Error Summary
-------------
Disk Requirements:
At least 4MB more space needed on the /boot filesystem.


解決方法

sudo package-cleanup --oldkernels で古いkernel を削除

3つぐらいkernel が削除された模様。

しかし、あんまりkernel をいくつかとっておく理由がよくわかんないなぁ(なんかロールバックすることあるんだろな