CentOS

CentOSをminimalでインストールしてscpを実行するには、openssh-clientsのインストールが必要です

More than 5 years have passed since last update.

CentOS 6.4をminimal(最小構成)でインストールすると、scpできない?

いろいろ探した結果、openssh-clientsがインッストールされていないので使用できない事がわかった。

ローカルのMacBookProから、お名前.comのVPSにインストールしたCentOS6.4にscpしようとしたところ、

macbookpro [userid] $ scp id_rsa.xxxxxx.pub [userid]@xxx.xxx.xxx.xxx:/home/[userid]

[userid]@xxx.xxx.xxx.xxx's password:[input password]

bash: scp: コマンドが見つかりません

lost connection

と表示され接続できない。。。

そこで分かったのは、openssh-clientsをyumでインストールしないといけないと言うこと!


yum install openssh-clients

これで無事に動作できた!!