scss
ATOM
lint
scss-lint

Atomのlinter-scss-lintに"you are using an old version of scss-lint"と怒られる

More than 1 year has passed since last update.


現象

linter-scss-lintプラグインがインストールされたAtomで、scss-lintのバージョンが古いとのエラーが出て動かない。

You are using an old version of scss-lint

スクリーンショット 2017-10-19 10.54.39.png

そこでscss-lintをアップデートしようとすると、「最新だよ」と言われてしまう。

$ gem list | grep scss-lint

scss-lint (0.38.0)
$ gem update scss-lint
Updating installed gems
Nothing to update


 解決策

lint-scssをアンインストールしてからscss_lintをインストールするとエラーが消えた。

gem uninstall scss-lint

gem uninstall scss_lint
gem install scss_lint

参考:Old version off scss-lint error message #160


ハマりポイント

scss-lintのバージョンが古い」というメッセージなのに、インストールするのはscss_lintになっている。

ちなみにプラグイン側のReadmeではちゃんと $ gem install scss_lint になっているので、rbenvでバージョンを変更した後などにハマりやすそう。

https://atom.io/packages/linter-scss-lint