Python
Eclipse
インストール
プラグイン
PyDev

EclipseにPydev5.2を追加してもPydevが表示されないとき(2016/8/30)

More than 1 year has passed since last update.


症状

 EclipseにPyDevプラグインをインストールしても、Perspective一覧や設定(の左ペインのツリー)にPyDevが表示されない。


原因

Pydevプラグインはバージョン(2016年8月最新はv5.2.0)によって対応するJava・Eclipseバージョンが異なり、対応があっていないとPyDevパースペクティブが表示されないため。


対策

 以下のような組み合わせでインストール・起動すること。


  • PyDev 5.2 の場合


    • (Eclipseを起動する)Javaランタイム   Java 8

    • Eclipseバージョン            Eclipse 4.5以降



  • PyDev 4.x の場合


    • (Eclipseを起動する)Javaランタイム   Java 7

    • Eclipseバージョン            Eclipse 3.8 ~ 4.4




参考

PyDev公式サイト (上記の内容はここから引用)

http://www.pydev.org/download.html

最新版PyDevプラグイン

http://pydev.org/updates