OandaのAPIで開発する時の注意点(2018年03月30日時点)

OandaのAPIで開発する時の注意点

Oanda Japanで口座を作った人はv20が使えません。
v1を使ってください。

英語版のアナウンスでは、2018年05月でv1終了とありますが、日本ではv1が引き続き使えます。

◯Introduction
http://developer.oanda.com/rest-live/introduction/

The OANDA v1 REST API is deprecated
The OANDA v1 REST API will cease to function for your account as early as May 2018.
Please migrate your applications to use the v20 REST API.

v20で作ったソースが全然動かなかったので、コールセンターに問い合わせをしました。

今後ですが、Oanda Japanとしてはv20への移行をする予定ですが、現時点では時期が未定ということでした。

v20が使いたければ、海外に移住してOanda本体に口座を作るしかありません。

Sign up for free and join this conversation.
Sign Up
If you already have a Qiita account log in.