10
Help us understand the problem. What are the problem?

More than 5 years have passed since last update.

posted at

updated at

Organization

ubuntu で RMagick を bundle install しようとしたらエラーがでた!

今更だけど、rubyでRMagickを使いたくて
rubygemsからインストールしようとしました。

ubuntu 12.04
ruby2.1.0

するとこんなエラーが・・・

ERROR:  Error installing rmagick:
    ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... yes
checking for ImageMagick version >= 6.4.9... yes
checking for HDRI disabled version of ImageMagick... yes
checking for stdint.h... yes
checking for sys/types.h... yes
checking for wand/MagickWand.h... no

Can't install RMagick 2.13.2. Can't find MagickWand.h.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/home/16bit_idol/.rvm/rubies/ruby-2.1.0/bin/ruby

MagickWand.h. がないらしい(・3・)

locate wand/MagickWand.h したら確かに無かった。
ImageMagickはインストール済みって確認したんだけどねぇ

なので、下記をインストール。

sudo apt-get install libmagickwand-dev

この後、問題なく RMagick が bundle install できましたとさ、おしまい。

Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
Sign upLogin
10
Help us understand the problem. What are the problem?