Edited at

Ruby用PDF生成ライブラリ「Prawn」のセットアップ方法

More than 1 year has passed since last update.


「Prawn」とは?

Ruby用のPDF生成ライブラリです。

YAMLによる履歴書作成スクリプトの動作に必要なのでインストールしました。

ちなみにインストールしないで make_cv.rb を実行すると以下のエラーが発生します。

$ ruby make_cv.rb

/Library/Ruby/Site/2.3.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- prawn (LoadError)
from /Library/Ruby/Site/2.3.0/rubygems/core_ext/kernel_require.rb:59:in `require'
from make_cv.rb:3:in `<main>'


環境


  • OS:macOS High Sierra 10.13.1

  • Ruby:ruby 2.3.3p222 (2016-11-21 revision 56859) [universal.x86_64-darwin17]

  • Gem:2.7.1


セットアップ

Gemからインストールするだけです。

$ sudo gem install -n /usr/local/bin prawn


参考リンク