Edited at

The python_package resource requires pip >= 6.1.0, currently 10.0.0

More than 1 year has passed since last update.


環境

pip 10.0.0

poise_python 1.6.0


エラー

STDERR: The python_package resource requires pip >= 6.1.0, currently 10.0.0


エラーの原因

poise_pythonの中で

pipの内部APIを叩こうとするが

pip 10から内部APIを外から叩くことができなくなっているので

エラーになる


解決法

poise_python 1.7.0から

新しいpip 10の仕様に対応するようになったので

1.7.0~ を使う


参考

https://github.com/poise/poise-python/issues/107