8
Help us understand the problem. What are the problem?

More than 5 years have passed since last update.

posted at

updated at

OS X targets using Swift cannot be built against an SDK older than 10.10, but the effective SDK is 10.9.

======================

問題

Xcode6の正式版がAppStoreでリリースされたのでアップデートしたのですが、OSX用に書いていたSwiftコードがコンパイルできなくなってしまいました。

どうやらv6.0.1のXcodeではyosemite v10.10のSDKが含まれていないようです。

OS X targets using Swift cannot be built against an SDK older than 10.10, but the effective SDK is 10.9.

解決策

以下のリンクよりXcode6.1Betaをダウンロードします。

ダウンロードしたXcode6.1Betaのdmgをマウントすると、MacOSX10.10.sdkのフォルダが以下のパスにあります。

/Volumes/Xcode/Xcode-Beta.app/Contents/Developer/Platforms/Developer/SDKs/

このMacOSX10.10.sdkのフォルダを、以下のパスにコピーします。

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/

参考

Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
Sign upLogin
8
Help us understand the problem. What are the problem?