Edited at

Dell Network Switch Sシリーズ(S4048)コマンドメモ

More than 1 year has passed since last update.

Dellのエンタープライズ向けスイッチである、Sシリーズ

そのS4048Tを実際に設定した際のメモを記載します。

これ誰あれば、とりあえずの設定は可能かと。

時間があれば、スタックとVRFのコマンドも追加します。


環境設定


ホスト名を設定

hostname s4048tsw01


SSHを有効

ip ssh server enable


SSHアクセスユーザーを作成

username admin password password privilege 15


タイムゾーン設定

clock timezone japan 9


NTPサーバーを設定 (mfeedを設定)

ntp server 210.173.160.86

ntp source Vlan 1


SNMP設定

snmp-server community public rw


管理ポートにIPを付与する

interface ManagementEthernet 1/1

ip address 192.168.1.254/24
no shutdown


管理ネットワークにデフォルトゲートウェイを設定

management route 0.0.0.0/0 192.168.1.1


スイッチ設定


ポートをトランクモードにする

interface range TenGigabitEthernet 1/1 - 1/48

portmode hybrid


スイッチモードにする(でないとスイッチとして動作しない)

interface range TenGigabitEthernet 1/1 - 1/48

switchport

先にportmode hybridをいれる

それから、switchportを流さないとエラーになる、


ポートを開ける

interface range TenGigabitEthernet 1/1 - 1/48

no shutdown


VLAN設定(作成とタグ割り当て)

interface Vlan 10

no ip address
untagged TenGigabitEthernet 1/1-1/48
no shutdown

interface Vlan 20

no ip address
tagged TenGigabitEthernet 1/1-1/48
no shutdown


40Gのポートを10G4ポートに分割する方法

オクトパスケーブルを利用することで、40Gの口を4つの10Gポートに変更できます。

構文例



stack-unit stack-unit-number port number portmode quad



スタック番号1で、1/49-52の40Gポートを10Gに変更したい場合

stack-unit 1 port number 49 quad

stack-unit 1 port number 50 quad
stack-unit 1 port number 51 quad
stack-unit 1 port number 52 quad

分割されたポートは「1/49/1」のようにサブポートが作成されます