rubyinstaller-2.2.3のインストール時にsqlite3で躓いた時

More than 3 years have passed since last update.


sqlite3で躓いたが…


rake --tasksでまた躓いた。(今度は、rakeでnokogiriやらbcypt_extやら…)

C:/ruby/lib/ruby/gems/2.0.0/gems/sqlite3-1.3.7-x86-mingw32/lib/sqlite3.rb:6:in `require':cannot load such file -- sqlite3/sqlite3_native (LoadError)

ネット上には様々な情報があるけれども、上記のエラーがでちゃった時には…

SQliteから、Precompiled Binaries for Windowsをダウンロードして、パスの通ったところ(渡しの場合はC:\Ruby22\bin)に移動させる。(今回は、32bit版です。)

Windows で SQLite3 の 64bit バイナリを自分で作る-Qiita

あたりを参考にすると幸せになれるかもしれません。

残念ながら64bit版は試していません。