0
Help us understand the problem. What are the problem?

posted at

updated at

【Emacs】Ubuntu22.04でJediを入れたらTypeErrorが起きた話

起こったこと

  • Ubuntu22.04
  • Python 3.10.4
  • GNU Emacs 28.1

の環境で

pip install jedi epc

したあと、emacs上でcompany-jediパッケージをインストール。
で、pyファイルを開いて編集すると、補完がされない。

Messageバッファでログをみると、以下のエラーメッセージを発見。

jedi deferred error : (error ""TypeError('Script.init() takes from 1 to 2 positional arguments but 5 positional arguments (and 1 keyword-only argument) were given

解決

emacsパッケージの方が、jedi(pythonライブラリ)の最新バージョン0.18に対応していないみたい。
古いバージョンをインストールしたら解決。

pip install jedi==0.17.2

参考:https://github.com/davidhalter/jedi/issues/1802

Register as a new user and use Qiita more conveniently

  1. You can follow users and tags
  2. you can stock useful information
  3. You can make editorial suggestions for articles
What you can do with signing up
0
Help us understand the problem. What are the problem?