Java
Eclipse
Tomcat

EclipseにTomcatプラグインをインストールする

Eclipseの設定が壊れて作り直したときに積んだのでメモ。
Tomcatプラグインをインストールする方法が変わったのか、自分の環境のせいなのか知らないけどググった情報が当てにならなかったので書いておきます。

一応環境

  • OS X 10.11.6
  • Eclipse Oxygen (4.7.3)

会社にあった手順書とネットの情報を見ても、「https://sourceforge.net/projects/tomcatplugin/files/
からプラグインをダウンロードして.zipを選択」
って書いてあるのにダウンロードできるのがzipじゃない。zipに圧縮してもインストールできない。

で、色々調べてたら上記リンクからダウンロードではなくて、

1. Eclipseの Help を開く
2. Eclipse Marketplace 選択
3. Find に"tomcat"と入れて検索
4. Eclipse Tomcat Plugin [バージョン] をインストール

これでできました。

そのあとEclipseを再起動するとEclipse > 環境設定 にTomcatの項目が追加されます。
バージョンは3.3から9.xまで入っていたのでこれで大抵の場合は問題ないかと思われます。

しょーもないことなんだけど、毎回この手順でググって積んでいる気がする……。