Help us understand the problem. What is going on with this article?

scrapyがpython3.7環境で動くようになったよ

More than 1 year has passed since last update.

3ヶ月ほど前、python3.7環境で動かした際に、下記参考ページに記載されているようなエラーが発生しました。
参考ページのリンク先にも説明がある通り、twistedがpython3.7に対応していないためのようです。

[Python]Scrapyを動かした時にSyntaxError: invalid syntaxとエラーが出る場合の対処法

2018-10-10にtwistedがpython3.7に対応

めでたく、2018-10-10に、twistedがpython3.7に対応しました。

Python 3.7 is now supported. (#9502)

twisted/NEWS.rst at twisted-18.9.0 · twisted/twisted

Dockerfile :whale: に下記設定をしたところ、問題なく動きました。

FROM python:3.7

RUN pip install -U pip
RUN pip install scrapy

twistedが18.9になっていますね :ok_hand:

root@b4df9d560d37:/usr/src/app# pip freeze | grep -e Twisted -e Scrapy
Scrapy==1.5.1
Twisted==18.9.0
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
Comments
No comments
Sign up for free and join this conversation.
If you already have a Qiita account
Why do not you register as a user and use Qiita more conveniently?
You need to log in to use this function. Qiita can be used more conveniently after logging in.
You seem to be reading articles frequently this month. Qiita can be used more conveniently after logging in.
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
ユーザーは見つかりませんでした