Flutter

Flutter コマンドが `Unable to pub upgrade flutter tool` で失敗する場合には

More than 1 year has passed since last update.

Flutter のバージョンを 0.1.3 から 0.0.20 へ切り替えて使おうとして、以下のエラーに遭遇した。

> flutter doctor

Building flutter tool...
Package file has no versions that match 2.3.4 derived from:
- flutter_tools depends on version 2.3.4
Error: Unable to pub upgrade flutter tool. Retrying in five seconds...

バージョンを切り替えたあとの、初回の flutter コマンド実行時には、関連ツールのダウンロードやビルドが実行される。しかし、それ自体でエラーになっている。

0.0.21 で依存パッケージのバージョンが上がったのが関係しているかも、と思ったので詳細を調査する前にキャッシュを消してみたところ、動くようになった。

rm -rf /path/to/flutter/bin/cache/