Help us understand the problem. What is going on with this article?

業務用ルータNEC IX2015を使ってみる

More than 5 years have passed since last update.

IX2015を導入した経緯

我が家には

  • クライアント10台
  • 自宅サーバ1-3台
  • NAS1台

程度があるのですが、それの上にあるルータが最近不安定だったんです。というわけで、いっその事業務用のルータにしてしまおうと。
そういう訳でした。
んじゃあ、どれにする?業務でも使ってるしCisco?とか思ったのだが、糞高い!
そんな大層な環境にしなくてもいいと思い、小規模オフィス、SOHO、研究室などへの導入でなかなか定評があるNECのIX2015を導入した。

IX2015

基本的にFastEtherしかついてないのだが、外との通信で100Mbps以上出ることもないのでよしとする。
ちなみにこいつ、中古でだいたい1000円~3000円。
http://auctions.search.yahoo.co.jp/search?auccat=&p=ix2015&tab_ex=commerce&ei=euc-jp

WiFiのアクセスポイントには、これを導入するまで使っていたBuffaloのwzr-600dhpを使うことにする。

設定例

というわけで、こんな感じに設定しました。
うちはOCNを使っているので、普通にPPPoEするだけでした。
IX2015に全部やらせます。NATもDHCPもね。
コピペしたらそのまま使えるような気がします。

WiFiのアクセスポイントはブリッジモードとやらで動かしています。

! NEC Portable Internetwork Core Operating System Software
 ! IX Series IX2010 (magellan-sec) Software, Version 8.3.48, RELEASE SOFTWARE
 ! Compiled May 10-Tue-2011 15:33:32 JST #1
 ! Last updated Sep 08-Sun-2013 12:09:25 JST
 !
 !ホスト名とタイムゾーンを設定。日本なので9です。
 hostname ix2015
 timezone +09 00
 !
 !
 !
 !
 !
 !時計合わせをちゃんとしましょう。
 ntp ip enable
 ntp server 133.243.238.242
 ntp server 210.173.160.27
 ntp retry 3
 ntp interval 3600
 !
 !
 !
 !
 !ufsキャッシュを有効にします。
 ip ufs-cache enable
 ip route default FastEthernet0/1.1
 !
 !前述のとおりdhcpもIX2015でやります
 ip dhcp enable
 !
 !自宅サーバを外からアクセスするために許可リストを作成します。ポート番号は全部xxにしてます
 ip access-list console permit ip src any dest 192.168.0.0/24
 ip access-list gwmng-pass permit udp src any sport any dest any dport eq xx
 ip access-list server permit tcp src any sport any dest any dport eq xx
 ip access-list server permit tcp src any sport any dest any dport eq xx
 ip access-list server permit tcp src any sport any dest any dport eq xx
 !
 !
 !
 !snmpを有効にします
 snmp-agent ip enable
 snmp-agent ip community xx management
 !
 !
 !DNSキャッシュを有効にします
 dns cache enable
 !
 !consoleケーブルでいちいちするのはめんどいのでtelnetでアクセスできるようにします
 telnet-server ip enable
 telnet-server ip access-list console
 !
 !なんとIX2015はweb管理画面があるのでアクセスできるようにします
 http-server username admin
 http-server ip access-list console
 http-server ip enable
 !
 !
 !
 !
 !
 !
 !
 !PPPoEの設定です。コピペすれば使えるんじゃないかな。接続情報は隠してあります。
 ppp profile ocn
 authentication myname xx@xx.ocn.ne.jp
 authentication password xx@xx.ocn.ne.jp yyyy
 !
 !DHCPの設定を書きます。
 ip dhcp profile lan
 assignable-range 192.168.0.2 192.168.0.200
 default-gateway 192.168.0.254
 dns-server 221.113.139.250 202.234.232.6
 !
 device FastEthernet0/0
 !
 device FastEthernet0/1
 !
 device FastEthernet1/0
 !
 device BRI1/0
 isdn switch-type hsd128k
 !
 interface FastEthernet0/0.0
 ip address 192.168.0.254/24
 ip dhcp binding lan
 no shutdown
 !
 interface FastEthernet0/1.0
 no ip address
 shutdown
 !
 interface FastEthernet1/0.0
 no ip address
 shutdown
 !
 interface BRI1/0.0
 encapsulation ppp
 no auto-connect
 no ip address
 shutdown
 !
 !naptを書いてポートを開けます。ポート番号は隠してます。
 interface FastEthernet0/1.1
 encapsulation pppoe
 auto-connect
 ppp binding ocn
 ip address ipcp
 ip napt enable
 ip napt service http 192.168.0.xx none tcp xx
 ip napt service ssh 192.168.0.xx none tcp xx
 ip napt service cod1 192.168.0.xx none udp xxxx
 ip napt service cod2 192.168.0.xx none tcp xxxx
 ip napt service cod3 192.168.0.xx none tcp xxxx
 ip napt service cod4 192.168.0.xx none udp xxxx
 ip napt service cod5 192.168.0.xx none udp xxxx
 ip napt service cod6 192.168.0.xx none udp xxxx
 no shutdown
 !
 interface Loopback0.0
 no ip address
 !
 interface Null0.0
 no ip address
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
Comments
No comments
Sign up for free and join this conversation.
If you already have a Qiita account
Why do not you register as a user and use Qiita more conveniently?
You need to log in to use this function. Qiita can be used more conveniently after logging in.
You seem to be reading articles frequently this month. Qiita can be used more conveniently after logging in.
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
ユーザーは見つかりませんでした