PHP
WordPress
jQuery
GoogleCloudPlatform

Google Cloud Platform から「ご対応ください: 重大な問題」のメールが来た


Google Cloud Platformから以下のメールが来ました。

 image.png

構築したGCE(Google Compute Engine)環境を送信元とし、

リモートポートに対するポート スキャニングが検出されたとのこと。

この問題は、

プロジェクトからサードパーティに送信されるトラフィックが意図したものであり、

プロジェクトが不正使用されていないことを確認することで解決できるとあります。

対応をしないと72時間後にインスタンスを停止するとあります!!

 image.png

「異議を申し立てる」ボタンがあるので、押してみる

 image.png

Google Cloud Platformコンソール画面に飛ばされる

(警告を受けたことが表示され、[異議を申し立てる]ボタンを押してみる

 image.png

異議を申し立てる画面では、対応してから対応内容を送信する内容となっている

 image.png

 image.png

本投稿は上記のメールが来ての対応した内容を纏めた内容となります。

(2019年4月時点の情報となります)

WordPrassをGoogle Compute Engineで構築している方がいて

同様のメールが来ている方がいると思いますので参考にしてください。


Google Cloud Platformから警告を受けた環境

Google Compute Engine(GCE)にWordpressを構築している環境があります。

■環境構築した内容は以下の記事を参照ください


 紙ベースで実施されていた運用をシステム化してみた

上記記事の環境のソフトウェアバージョン

 =====

  WordPress : 5.0.4

  PHP : 5.4.16

  Apache: 2.4.6

  MySQL:15.1

 =====


警告を受けた原因

警告メールからサードパーティのソフトウェアとあるので調べてみたところ

以下の記事がありました。

WordPressに脆弱性、アップデートを

WordPressの環境は「 5.0.4」だったので、まずはアップデートをする必要がある!


対応

以下の対応を行いました

1.作成した環境をバックアップ

2.WordPressのアップデート

3.Cloud Web Security Scannerで脆弱性をスキャン


1.作成した環境をバックアップ

簡単にエクスポート、別環境にインポートできるとのことで

プラグイン「All-in-One WP Migration」を使用しました。

(仮にインスタンスを停止になった場合、別環境でインポートできるプラグインを検討)

■参考までにプラグイン追加方法

 image.png

■エクスポート方法

image.png

image.png

image.png

image.png


2.WordPressのアップデート

画面キャプチャでは、すでに最新版に更新された後になってますが、

最新バージョンでない場合、最新版にインスールするボタンが押せる状態だったと思います。

※WordPressのバージョンアップ 5.0.4 ==> 5.1.1

image.png


3.Cloud Web Security Scannerで脆弱性をスキャン

WordPressを最新バージョンにしたので、Cloud Web Security Scannerで脆弱性をスキャン

image.png

スキャン開始するジョブを作成します

image.png

image.png

image.png

image.png

image.png

image.png


WordPressのアップデートだけでは脆弱性は解消されず

WordPressのダッシュボード画面にPHPが古いというメッセージがあったので

PHPのバージョンアップを実施

sudo yum install epel-release

sudo rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-7.rpm
sudo yum remove php-*

sudo yum install --disablerepo=* --enablerepo=epel,remi,remi-php73 php
sudo yum install --disablerepo=* --enablerepo=remi,remi-php73 php-mysqlnd php-mysql php-mbstring php-intl

PHPのバージョンを

5.4.16 ==> 7.3.4 に更新。

で、再度、Cloud Web Security Scannerで脆弱性をスキャン

今度はJquery 1.12.4 がだめらしい。。

image.png

WordPressでJqueryの使用バージョンを3.00に変更

変更はfunctions.php に以下の記載をします。


functions.php


function change_jquery() {
if( !is_admin() ){
wp_deregister_script('jquery');
wp_enqueue_script('jquery', '//cdn.jsdelivr.net/jquery/jquery-3.0.0.min.js', array(), null , true);
}
}
add_action('init', 'change_jquery');


そして、再度、Cloud Web Security Scannerで脆弱性をスキャンしたら

脆弱性は「0」になりました。


Google Cloud Platformに異議を申し立てる

脆弱性に対する対応が完了したので異議を申し立てる画面を入力。

image.png

対応した内容とCloud Web Security Scannerを実施して問題ないことを書きました。

すると、Googleからメールが送信される。

image.png

※2営業日以内に返事があるとのこと


結果

今回対応した内容で申請が通りました。

image.png


関連リンク

紙ベースで実施されていた運用をシステム化してみた

※Google Compute Engine(GCE)、WordPress、PHP、MySQLを使用した記事です