reactnative
react-native

React Nativeでnode moduleを使おうとしたらエラーでた。

More than 1 year has passed since last update.

タイトルの通りなんだけどエラーでた。
モジュールの解決に失敗している様子。

原因

対処法的なの一通りしたところで気がついた。

Node.jsのeventsモジュールが無くてエラー出てることに・・・
実はエラー文にちゃんと書いてあった。

React NativeはJSのエンジンとしてJavaScriptCoreを使っているので、Nodeのnativeなモジュールを使っているようなモジュールは読み込めないのだった。

反省

思い込みカッコ悪い。