1
1

Delete article

Deleted articles cannot be recovered.

Draft of this article would be also deleted.

Are you sure you want to delete this article?

IX ルータで BGP4 を使ってみる

Last updated at Posted at 2023-10-14

使ったルータ

NEC IX3110 10.5.33 (2023.6.30 リリース)

IX ルータの初期設定

config を初期化した上で以下を入力

hostname おなまえ
timezone +09 00
! ter len 0 的なデフォルト設定
terminal default-length 0
terminal default-width 512
! シリアルの通信速度設定
terminal speed 38400
!
! ログの設定
logging buffered 131072
logging subsystem all warn
logging timestamp datetime
ip ufs-cache enable
!
! ssh の設定
username ix-admin password plain ix-admin administrator
service password-encryption
ssh-server ip enable

この辺りの設定は共通のため、以下では省略。

先ずは 2台でやってみる

image.png

LAN側のインターフェースは仮に Loopback にしておく。
ルータ間はセグメントが異なるので /32 でルーティングを書く。

RT-11
hostname RT-11
!
ip route 100.64.21.1/32 100.64.21.1 GigaEthernet0.0 connected
router bgp 40010
  neighbor 100.64.21.1 remote-as 40020
  address-family ipv4 unicast
    network 10.0.11.0/24
!
interface GigaEthernet0.0
  ip address 100.64.11.1/32
  no shutdown
!
interface Loopback0.0
  ip address 10.0.11.100/24

ip route 100.64.21.1/32 100.64.21.1 GigaEthernet0.0 connected Gi0.0 の先に 100.64.21.1 が直接繋がっている。
router bgp 40010 で、自分の AS 番号を定義
neighbor 100.64.21.1 remote-as 40020 隣接している AS 番号と、そのルータの IP アドレス
address-family ipv4 unicast の後に network 10.0.11.0/24 で、自分が接している (next-hop になる) ネットワークを BGP に広告。

RT-21
hostname RT-21
!
ip route 100.64.11.1/32 100.64.11.1 GigaEthernet0.0 connected
router bgp 40020
  neighbor 100.64.11.1 remote-as 40010
  address-family ipv4 unicast
    network 10.0.21.0/24
!
interface GigaEthernet0.0
  ip address 100.64.21.1/32
  no shutdown
!
interface Loopback0.0
  ip address 10.0.21.100/24

ip route 100.64.11.1/32 100.64.11.1 GigaEthernet0.0 connected Gi0.0 の先に 100.64.11.1 が直接繋がっている。
router bgp 40020 このルータの所属している AS 番号
neighbor 100.64.11.1 remote-as 40010 隣接している AS 番号と、そのルータの IP アドレス
address-family ipv4 unicast の中に network 10.0.21.0/24 を記載し、このルータに隣接しているネットワークを BGP で広告

RT-21 route
RT-21(config)# show ip route
IP Routing Table - 4 entries, 3 hidden, 2041 frees
Entries: 2 Connected, 1 Static, 0 RIP, 0 OSPF, 1 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     10.0.0.0/8 is subnetted, 2 subnets
B      10.0.11.0/24 [20/0] via 100.64.11.1, GigaEthernet0.0, 0:29:56
C      10.0.21.0/24 [0/0] is directly connected, Loopback0.0, 0:31:04
     100.0.0.0/8 is subnetted, 2 subnets
S      100.64.11.1/32 [1/1] via 100.64.11.1, GigaEthernet0.0, 0:30:54
C      100.64.21.1/32 [0/0] is directly connected, GigaEthernet0.0, 0:31:04

RT-21(config)# show ip bgp all
BGP table version is 2, local router ID is 10.0.21.100
Local AS number 40020
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
*> 10.0.11.0/24       100.64.11.1              0             40010 i
*> 10.0.21.0/24       0.0.0.0                  0             i

Total number of prefixes 2
RT-21(config)#
RT-21(config)# show ip bgp paths
Address    RefCount Next Hop               MED      LocPrf  Path
0x069a2180        2 0.0.0.0                  0*        100  i
0x06a4ab00        4 100.64.11.1              0*        100  40010 i
0x06a4a940        1 100.64.21.1              0*        100  i
RT-21(config)#
RT-21(config)# show ip bgp 10.0.11.0/24
RIB entry for 10.0.11.0/24, table version 1
  RIB-IN entry:
    Received from neighbor 100.64.11.1 (10.0.11.100) 0:44:49 ago
      Nexthop 100.64.11.1, Origin IGP, MED 0, Localpref 100
      AS path 40010
      External, Best, Valid
      IGP protocol is static metric 1
      Outgoing interface is GigaEthernet0.0 100.64.11.1
RT-21(config)# show ip bgp 10.0.21.0/24
RIB entry for 10.0.21.0/24, table version 0
  RIB-IN entry:
    Local originated 0:45:59 ago
      Nexthop 0.0.0.0, Origin IGP, MED 0, Localpref 100
      AS path local
      Local, Best, Valid
  RIB-OUT entry:
    Advertised to neighbor 100.64.11.1 (10.0.11.100) 0:44:52 ago
      Nexthop 100.64.21.1, Origin IGP, MED 0
      AS path local
RT-21(config)#
RT-21 ping
RT-21(config)# ping 10.0.11.100 source 10.0.21.100
PING 10.0.21.100 > 10.0.11.100 56 data bytes
64 bytes from 10.0.11.100: icmp_seq=0 ttl=64 time=0.095 ms
64 bytes from 10.0.11.100: icmp_seq=1 ttl=64 time=0.078 ms
64 bytes from 10.0.11.100: icmp_seq=2 ttl=64 time=0.084 ms
64 bytes from 10.0.11.100: icmp_seq=3 ttl=64 time=0.081 ms
64 bytes from 10.0.11.100: icmp_seq=4 ttl=64 time=0.082 ms

--- 10.0.11.100 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0.078/0.084/0.095
RT-21(config)#

ルータ 4台 AS 2つ

image.png

RT-11 は先程と同じ。RT-21 の 下に RT-22, RT-23 を接続し、BGP4 でルーティング。
RT-21,RT-22,RT-23 の間 (172.16.0.0/24) は HUB で繋ぎます。

RT-11
hostname RT-11
ip route 100.64.21.1/32 100.64.21.1 GigaEthernet0.0 connected
!
router bgp 65010
  neighbor 100.64.21.1 remote-as 65020
  address-family ipv4 unicast
    network 10.0.11.0/24
!
interface GigaEthernet0.0
  ip address 100.64.11.1/32
  no shutdown
!
interface Loopback0.0
  ip address 10.0.11.100/24
RT-21
hostname RT-21
ip route 100.64.11.1/32 100.64.11.1 GigaEthernet0.0 connected
!
router bgp 65020
  neighbor 100.64.11.1 remote-as 65010
  neighbor 172.16.0.22 remote-as 65020
  neighbor 172.16.0.23 remote-as 65020
  address-family ipv4 unicast
    neighbor 172.16.0.22 next-hop-self
    neighbor 172.16.0.23 next-hop-self
    network 172.16.0.0/24
    aggregate-address 172.17.22.0/23 summary-only
!
interface GigaEthernet0.0
  ip address 100.64.21.1/32
  no shutdown
!
interface GigaEthernet1.0
  ip address 172.16.0.21/24
  no shutdown
RT-22
router bgp 65020
  neighbor 172.16.0.21 remote-as 65020
  neighbor 172.16.0.23 remote-as 65020
  address-family ipv4 unicast
    network 172.17.22.0/24
!
interface GigaEthernet0.0
  ip address 172.16.0.22/24
  no shutdown
!
interface Loopback0.0
  ip address 172.17.22.100/24
!
RT-22(config)#
RT-23
hostname RT-23
router bgp 65020
  neighbor 172.16.0.21 remote-as 65020
  neighbor 172.16.0.22 remote-as 65020
  address-family ipv4 unicast
    network 172.17.23.0/24
!
interface GigaEthernet0.0
  ip address 172.16.0.23/24
  no shutdown
!
interface Loopback0.0
  ip address 172.17.23.100/24

RT-21 と、RT-22 を接続、RT-23 は未接続の状態と、接続後の状態。

RT-21(config)# sh ip bgp summary
BGP router ID 10.0.21.100, local AS number 40020
2 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.11.1     4    40010 175     178     2:52:34       ESTABLISHED
 172.16.0.22     4    40020 3       5       0:00:38       ESTABLISHED
 172.16.0.23     4    40020 0       0       0:00:00       ACTIVE
RT-21(config)# sh ip bgp summary
BGP router ID 10.0.21.100, local AS number 40020
2 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.11.1     4    40010 178     181     2:55:07       ESTABLISHED
 172.16.0.22     4    40020 6       8       0:03:11       ESTABLISHED
 172.16.0.23     4    40020 3       5       0:00:09       ESTABLISHED

RT-21(config)# show ip route
IP Routing Table - 7 entries, 5 hidden, 2036 frees
Entries: 2 Connected, 1 Static, 0 RIP, 0 OSPF, 4 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     10.0.0.0/8 is subnetted, 1 subnets
B      10.0.11.0/24 [20/0] via 100.64.11.1, GigaEthernet0.0, 0:10:45
     100.0.0.0/8 is subnetted, 2 subnets
S      100.64.11.1/32 [1/1] via 100.64.11.1, GigaEthernet0.0, 0:10:47
C      100.64.21.1/32 [0/0] is directly connected, GigaEthernet0.0, 0:10:47
     172.16.0.0/16 is subnetted, 1 subnets
C      172.16.0.0/24 [0/0] is directly connected, GigaEthernet1.0, 0:05:13
     172.17.0.0/16 is subnetted, 3 subnets
B s    172.17.22.0/23 [255/0] is directly connected, Null0.0, 0:05:13
B      172.17.22.0/24 [200/0] via 172.16.0.22, GigaEthernet1.0, 0:05:13
B      172.17.23.0/24 [200/0] via 172.16.0.23, GigaEthernet1.0, 0:02:11

RT-21 の next-hop-self がなかった場合

RT-21
router bgp 65020
  neighbor 100.64.11.1 remote-as 65010
  neighbor 172.16.0.22 remote-as 65020
  neighbor 172.16.0.23 remote-as 65020
  address-family ipv4 unicast
!   neighbor 172.16.0.22 next-hop-self
!   neighbor 172.16.0.23 next-hop-self
    network 172.16.0.0/24
    aggregate-address 172.17.22.0/23 summary-only
RT-23
RT-23(config)# show ip bgp summary
BGP router ID 172.17.23.100, local AS number 65020
2 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 172.16.0.21     4    65020 40      31      0:14:33       ESTABLISHED
 172.16.0.22     4    65020 30      33      0:04:34       ESTABLISHED

Total number of neighbors 2
RT-23(config)#
RT-23(config)# show ip route
IP Routing Table - 4 entries, 3 hidden, 2041 frees
Entries: 2 Connected, 0 Static, 0 RIP, 0 OSPF, 2 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     172.16.0.0/16 is subnetted, 1 subnets
C      172.16.0.0/24 [0/0] is directly connected, GigaEthernet0.0, 0:07:03
     172.17.0.0/16 is subnetted, 3 subnets
B      172.17.22.0/23 [200/0] via 172.16.0.21, GigaEthernet0.0, 0:07:01
B      172.17.22.0/24 [200/0] via 172.16.0.22, GigaEthernet0.0, 0:03:20
C      172.17.23.0/24 [0/0] is directly connected, Loopback0.0, 3:01:44

BGP は、RT-23 から RT-21 が見えていますが、RT-11 向けのルーティング (10.0.11.100/24) が来ていません。
一方で RT-11 はルーティングが来ています。(戻りがないため、通信はできません)

RT-11
RT-11(config)# show ip route
IP Routing Table - 5 entries, 5 hidden, 2038 frees
Entries: 2 Connected, 1 Static, 0 RIP, 0 OSPF, 2 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     10.0.0.0/8 is subnetted, 1 subnets
C      10.0.11.0/24 [0/0] is directly connected, Loopback0.0, 6:07:33
     100.0.0.0/8 is subnetted, 2 subnets
C      100.64.11.1/32 [0/0] is directly connected, GigaEthernet0.0, 3:19:01
S      100.64.21.1/32 [1/1] via 100.64.21.1, GigaEthernet0.0, 3:19:01
     172.16.0.0/16 is subnetted, 1 subnets
B      172.16.0.0/24 [20/0] via 100.64.21.1, GigaEthernet0.0, 0:16:13
     172.17.0.0/16 is subnetted, 1 subnets
B      172.17.22.0/23 [20/0] via 100.64.21.1, GigaEthernet0.0, 0:16:13

ここで、RT-21 に neighbor 172.16.0.X next-hop-self を投入します。

RT-21
RT-21(config)# router bgp 65020
RT-21(config-bgp)#   address-family ipv4 unicast
RT-21(config-bgp-af4)#     neighbor 172.16.0.22 next-hop-self
% Need to reset neighbor 172.16.0.22 to take effect of the command.
RT-21(config-bgp-af4)#     neighbor 172.16.0.23 next-hop-self
% Need to reset neighbor 172.16.0.23 to take effect of the command.
RT-21(config-bgp-af4)# exi
RT-21(config-bgp)# exit
RT-21(config)#

反映させるには 172.16.0.22 (RT-22) と 172.16.0.23 (RT-23) をリセットしろと言われます。
勿論電源 OFF/ON でも良いのでしょうが、それぞれの機器で clear コマンドを叩きます。

RT-22(config)# clear ip bgp *

RT-23(config)# clear ip bgp *

一度接続が切れますので、暫く待ちます。

show ip bgp ...
RT-21(config)# show ip bgp
BGP table version is 32, local router ID is 172.16.0.21
Local AS number 65020
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
*> 10.0.11.0/24       100.64.11.1              0             65010 i
*> 172.16.0.0/24      0.0.0.0                  0             i

Total number of prefixes 2
RT-21(config)# show ip bgp summary
BGP router ID 172.16.0.21, local AS number 65020
2 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.11.1     4    65010 51      62      0:47:51       ESTABLISHED
 172.16.0.22     4    65020 49      63      0:01:04       IDLE
 172.16.0.23     4    65020 49      60      0:00:59       IDLE

Total number of neighbors 3

いろいろやって待ってると接続が戻る。

show ip bgp ...
RT-21(config)# show ip bgp summary
BGP router ID 172.16.0.21, local AS number 65020
2 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.11.1     4    65010 55      67      0:51:10       ESTABLISHED
 172.16.0.22     4    65020 54      70      0:02:23       ESTABLISHED
 172.16.0.23     4    65020 54      67      0:02:18       ESTABLISHED

Total number of neighbors 3
RT-21(config)#

3台とも ESTABLISHED になりました。

もう一度 RT-23 でルーティングを見てみると

RT-23
RT-23(config)# show ip bgp summary
BGP router ID 172.17.23.100, local AS number 65020
2 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 172.16.0.21     4    65020 335     324     0:05:30       ESTABLISHED
 172.16.0.22     4    65020 323     324     0:05:38       ESTABLISHED

Total number of neighbors 2

Neighbor は変化無し。

RT-23
RT-23(config)# show ip route
IP Routing Table - 5 entries, 4 hidden, 2039 frees
Entries: 2 Connected, 0 Static, 0 RIP, 0 OSPF, 3 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     10.0.0.0/8 is subnetted, 1 subnets
B      10.0.11.0/24 [200/0] via 172.16.0.21, GigaEthernet0.0, 0:05:34
     172.16.0.0/16 is subnetted, 1 subnets
C      172.16.0.0/24 [0/0] is directly connected, GigaEthernet0.0, 4:58:58
     172.17.0.0/16 is subnetted, 3 subnets
B      172.17.22.0/23 [200/0] via 172.16.0.21, GigaEthernet0.0, 0:05:34
B      172.17.22.0/24 [200/0] via 172.16.0.22, GigaEthernet0.0, 0:05:42
C      172.17.23.0/24 [0/0] is directly connected, Loopback0.0, 7:53:38

10.0.11.0/24 のルーティングが来ました。

AS 内にルータ 4台

image.png
冗長性を考えれば RT-11 ↔ RT-14 を結ぶ必要もありますが、それがないとどうなるか。

RT-11
router bgp 65010
  neighbor 100.64.0.1 remote-as 65010
  neighbor 100.64.0.3 remote-as 65010
  address-family ipv4 unicast
    network 10.0.11.0/24
!

interface GigaEthernet0.0
  ip address 100.64.0.0/31
  no shutdown
!
interface GigaEthernet1.0
  ip address 100.64.0.2/31
  no shutdown
!
interface Loopback0.0
  ip address 10.0.11.100/24
RT-12
router bgp 65010
  neighbor 100.64.0.0 remote-as 65010
  neighbor 100.64.0.5 remote-as 65010
  neighbor 100.64.0.9 remote-as 65010
  address-family ipv4 unicast
    network 10.0.12.0/24
!

interface GigaEthernet0.0
  ip address 100.64.0.1/31
  no shutdown
!
interface GigaEthernet1.0
  ip address 100.64.0.4/31
  no shutdown
!
interface GigaEthernet2.0
  ip address 100.64.0.8/31
  no shutdown
!
interface Loopback0.0
  ip address 10.0.12.100/24
RT-13
router bgp 65010
  neighbor 100.64.0.2 remote-as 65010
  neighbor 100.64.0.7 remote-as 65010
  neighbor 100.64.0.8 remote-as 65010
  address-family ipv4 unicast
    network 10.0.13.0/24
!

interface GigaEthernet0.0
  ip address 100.64.0.3/31
  no shutdown
!
interface GigaEthernet1.0
  ip address 100.64.0.6/31
  no shutdown
!
interface GigaEthernet2.0
  ip address 100.64.0.9/31
  no shutdown
!
interface Loopback0.0
  ip address 10.0.13.100/24
RT-14
router bgp 65010
  neighbor 100.64.0.4 remote-as 65010
  neighbor 100.64.0.6 remote-as 65010
  address-family ipv4 unicast
    network 10.0.14.0/24
!
interface GigaEthernet0.0
  ip address 100.64.0.5/31
  no shutdown
!
interface GigaEthernet1.0
  ip address 100.64.0.7/31
  no shutdown
!
interface Loopback0.0
  ip address 10.0.14.100/24

show ip bgp summary

RT-11
RT-11(config)# show ip bgp summary
BGP router ID 10.0.11.100, local AS number 65010
1 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.0.1      4    65010 21      21      0:18:54       ESTABLISHED
 100.64.0.3      4    65010 16      18      0:10:27       ESTABLISHED

Total number of neighbors 2
RT-12
Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.0.0      4    65010 22      22      0:19:13       ESTABLISHED
 100.64.0.5      4    65010 20      20      0:17:26       ESTABLISHED
 100.64.0.9      4    65010 20      20      0:17:13       ESTABLISHED
RT-13
Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.0.2      4    65010 16      18      0:10:47       ESTABLISHED
 100.64.0.7      4    65010 18      18      0:15:08       ESTABLISHED
 100.64.0.8      4    65010 20      20      0:17:14       ESTABLISHED
RT-14
Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.0.4      4    65010 20      20      0:17:27       ESTABLISHED
 100.64.0.6      4    65010 18      18      0:15:09       ESTABLISHED

全て接続完了

show ip route

RT-11
RT-11(config)# show ip route
...
Timers: Age
     10.0.0.0/8 is subnetted, 3 subnets
C      10.0.11.0/24 [0/0] is directly connected, Loopback0.0, 0:25:48
B      10.0.12.0/24 [200/0] via 100.64.0.1, GigaEthernet0.0, 0:25:32
B      10.0.13.0/24 [200/0] via 100.64.0.3, GigaEthernet1.0, 0:17:06
     100.0.0.0/8 is subnetted, 2 subnets
C      100.64.0.0/31 [0/0] is directly connected, GigaEthernet0.0, 0:25:48
C      100.64.0.2/31 [0/0] is directly connected, GigaEthernet1.0, 0:17:55
RT-11(config)#
RT-12
Timers: Age
     10.0.0.0/8 is subnetted, 4 subnets
B      10.0.11.0/24 [200/0] via 100.64.0.0, GigaEthernet0.0, 0:25:39
C      10.0.12.0/24 [0/0] is directly connected, Loopback0.0, 0:25:48
B      10.0.13.0/24 [200/0] via 100.64.0.9, GigaEthernet2.0, 0:23:39
B      10.0.14.0/24 [200/0] via 100.64.0.5, GigaEthernet1.0, 0:23:51
     100.0.0.0/8 is subnetted, 3 subnets
C      100.64.0.0/31 [0/0] is directly connected, GigaEthernet0.0, 0:25:48
C      100.64.0.4/31 [0/0] is directly connected, GigaEthernet1.0, 0:24:14
C      100.64.0.8/31 [0/0] is directly connected, GigaEthernet2.0, 0:23:44
RT-12(config)#
RT-13
Timers: Age
     10.0.0.0/8 is subnetted, 4 subnets
B      10.0.11.0/24 [200/0] via 100.64.0.2, GigaEthernet0.0, 0:17:17
B      10.0.12.0/24 [200/0] via 100.64.0.8, GigaEthernet2.0, 0:23:44
C      10.0.13.0/24 [0/0] is directly connected, Loopback0.0, 0:25:47
B      10.0.14.0/24 [200/0] via 100.64.0.7, GigaEthernet1.0, 0:21:38
     100.0.0.0/8 is subnetted, 3 subnets
C      100.64.0.2/31 [0/0] is directly connected, GigaEthernet0.0, 0:18:02
C      100.64.0.6/31 [0/0] is directly connected, GigaEthernet1.0, 0:22:56
C      100.64.0.8/31 [0/0] is directly connected, GigaEthernet2.0, 0:23:56
RT-13(config)#
RT-14
Timers: Age     10.0.0.0/8 is subnetted, 3 subnets
B      10.0.12.0/24 [200/0] via 100.64.0.4, GigaEthernet0.0, 0:24:04
B      10.0.13.0/24 [200/0] via 100.64.0.6, GigaEthernet1.0, 0:21:45
C      10.0.14.0/24 [0/0] is directly connected, Loopback0.0, 0:25:45
     100.0.0.0/8 is subnetted, 2 subnets
C      100.64.0.4/31 [0/0] is directly connected, GigaEthernet0.0, 0:24:29
C      100.64.0.6/31 [0/0] is directly connected, GigaEthernet1.0, 0:23:07
RT-14(config)#

ルーティングが来ないので next-hop-self を入れてみる

RT-11 と RT-14 の間のルーティングがされていませんねぇ。
これはさっきの neighbor X.X.X.X next-hop-self がいるパターンでしょうか。
まず、中間の RT-12 の BGP 設定を以下のようにします。

RT-12
router bgp 65010
  neighbor 100.64.0.0 remote-as 65010
  neighbor 100.64.0.5 remote-as 65010
  neighbor 100.64.0.9 remote-as 65010
  address-family ipv4 unicast
    neighbor 100.64.0.0 next-hop-self
    neighbor 100.64.0.5 next-hop-self
    neighbor 100.64.0.9 next-hop-self
    network 10.0.12.0/24
RT-14
RT-14(config)# clear ip bgp *
RT-14(config)# show ip route
...
Timers: Age     10.0.0.0/8 is subnetted, 3 subnets
B      10.0.12.0/24 [200/0] via 100.64.0.4, GigaEthernet0.0, 0:01:52
B      10.0.13.0/24 [200/0] via 100.64.0.6, GigaEthernet1.0, 0:01:56
C      10.0.14.0/24 [0/0] is directly connected, Loopback0.0, 0:57:36
     100.0.0.0/8 is subnetted, 2 subnets
C      100.64.0.4/31 [0/0] is directly connected, GigaEthernet0.0, 0:56:20
C      100.64.0.6/31 [0/0] is directly connected, GigaEthernet1.0, 0:54:58

RT-14(config)# show ip bgp neighbors 100.64.0.4 received-routes
BGP table version is 15, local router ID is 10.0.14.100
Local AS number 65010
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
*>i10.0.12.0/24       100.64.0.4               0        100  i

Total number of prefixes 1

再接続されましたが、ルートは来ません。AS 内なので 'next-hop-self' では next-hop アドレスが書き換わりません。残念。

やはりルーティングが来ないのでルートリフレクタにする

BGP はそもそもフルメッシュであることを想定して作られたプロトコルなので、ルーティング情報が複数のルータを通過しないのです。(スプリットホライズン)
そのため、知っているルートを全て喋る「BGPルートリフレクタ」という機能でフルメッシュから、スター型でも動作可能になります。改めて以下のように書き換えます。

RT-12
router bgp 65010
  neighbor 100.64.0.0 remote-as 65010
  neighbor 100.64.0.0 route-reflector-client
  neighbor 100.64.0.5 remote-as 65010
  neighbor 100.64.0.5 route-reflector-client
  neighbor 100.64.0.9 remote-as 65010
  neighbor 100.64.0.9 route-reflector-client
  address-family ipv4 unicast
    network 10.0.12.0/24

このコマンドも % Need to reset neighbor X.X.X.X to take effect of the command. と言われるので
clear ip bgp * を実行...暫く待って

RT-14
RT-14(config)# show ip route
...
Timers: Age
     10.0.0.0/8 is subnetted, 3 subnets
B      10.0.12.0/24 [200/0] via 100.64.0.4, GigaEthernet0.0, 0:00:14
B      10.0.13.0/24 [200/0] via 100.64.0.6, GigaEthernet1.0, 0:00:15
C      10.0.14.0/24 [0/0] is directly connected, Loopback0.0, 1:44:32
     100.0.0.0/8 is subnetted, 2 subnets
C      100.64.0.4/31 [0/0] is directly connected, GigaEthernet0.0, 1:43:16
C      100.64.0.6/31 [0/0] is directly connected, GigaEthernet1.0, 1:41:54

ルーティングが追加されていませんねぇ。
RT-12 (100.64.0.4) から貰ったルートを見てみましょう。

RT-14
RT-14(config)# show ip bgp neighbors 100.64.0.4 received-routes
BGP table version is 13, local router ID is 10.0.14.100
Local AS number 65010
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
  i10.0.11.0/24       100.64.0.0               0        100  i
*>i10.0.12.0/24       100.64.0.4               0        100  i
  i10.0.13.0/24       100.64.0.9               0        100  i

Total number of prefixes 3

ルートが 3つ来ていますが、 * - valid が 一つしか付いていないですねぇ。
Next Hop が Next でない所を向いている (直接接続していないアドレス) からみたいです。

Next Hop を書き換えたいので next-hop-self を入れてみる

Next Hop を RT-12 に書き換えます。

RT-12
no router bgp 65010
router bgp 65010
  neighbor 100.64.0.0 remote-as 65010
  neighbor 100.64.0.0 route-reflector-client
  neighbor 100.64.0.5 remote-as 65010
  neighbor 100.64.0.5 route-reflector-client
  neighbor 100.64.0.9 remote-as 65010
  neighbor 100.64.0.9 route-reflector-client
  address-family ipv4 unicast
    neighbor 100.64.0.0 next-hop-self
    neighbor 100.64.0.5 next-hop-self
    neighbor 100.64.0.9 next-hop-self
    network 10.0.12.0/24

clear ip bgb * して見てみる

RT-14
RT-14(config)# show ip bgp neighbors 100.64.0.4 received-routes
BGP table version is 20, local router ID is 10.0.14.100
Local AS number 65010
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
  i10.0.11.0/24       100.64.0.0               0        100  i
*>i10.0.12.0/24       100.64.0.4               0        100  i
  i10.0.13.0/24       100.64.0.9               0        100  i

Total number of prefixes 3

どうやら、同 AS 内の Next Hop の書き換えはできないようです。

Next Hop が書き換えられなかったので、RT-12 に所属しているネットワークだと宣言してみる

RT-12
no router bgp 65010
router bgp 65010
  neighbor 100.64.0.0 remote-as 65010
  neighbor 100.64.0.0 route-reflector-client
  neighbor 100.64.0.5 remote-as 65010
  neighbor 100.64.0.5 route-reflector-client
  neighbor 100.64.0.9 remote-as 65010
  neighbor 100.64.0.9 route-reflector-client
  address-family ipv4 unicast
    network 10.0.11.0/24
    network 10.0.12.0/24
    network 10.0.13.0/24
    network 10.0.14.0/24

network コマンドで自分が所持しているネットワークだと経路情報を広告してみる。

RT-14
RT-14(config)# show ip bgp neighbors 100.64.0.4 received-routes
...
   Network            Next Hop            Metric     LocPrf  Path
  i10.0.11.0/24       100.64.0.0               0        100  i
*>i10.0.12.0/24       100.64.0.4               0        100  i
  i10.0.13.0/24       100.64.0.9               0        100  i

やっぱり駄目ですねぇ。
NEC の IX ルータ で BGP をメッシュ構成にできないときは AS を分割しないといけないようです。

BGP コンフェデレーションは非対応なので、完全に分割しないといけません。
BGP コンフェデレーションの説明は ➡ IBGP スケーリングのための BGP コンフェデレーション

えーっと、マニュアルを見直しました。next-hop-selfpeer-group の中で使うと上手くいきました。
そして 100.64.0.n を広告していませんでした。 RT-11,RT-13,RT14 は広告するアドレスを増やしただけですが、再掲します。

RT-11
router bgp 65010
  neighbor 100.64.0.1 remote-as 65010
  neighbor 100.64.0.3 remote-as 65010
  address-family ipv4 unicast
    network 10.0.11.0/24
    network 100.64.0.0/31
    network 100.64.0.2/31
!
interface GigaEthernet0.0
  ip address 100.64.0.0/31
  no shutdown
!
interface GigaEthernet1.0
  ip address 100.64.0.2/31
  no shutdown
!
interface Loopback0.0
  ip address 10.0.11.100/24

100.64.0.0/31 を使っているので広告するアドレスも /31 にします。(ルーティングテーブルに /31 で載っていて、ルーティングテーブルに載っている物しか広告しないため)

RT-12
route-map in-comming permit 10
  set metric 10
!
router bgp 65010
  address-family ipv4 unicast
    network 10.0.12.0/24
    network 100.64.0.0/31
    network 100.64.0.4/31
    network 100.64.0.8/31
  peer-group My-Home remote-as 65010
    neighbor 100.64.0.0 remote-as 65010
    neighbor 100.64.0.5 remote-as 65010
    neighbor 100.64.0.9 remote-as 65010
    route-reflector-client
    address-family ipv4 next-hop-self
    address-family ipv4 route-map in-comming in
!
interface GigaEthernet0.0
  ip address 100.64.0.1/31
  no shutdown
!
interface GigaEthernet1.0
  ip address 100.64.0.4/31
  no shutdown
!
interface GigaEthernet2.0
  ip address 100.64.0.8/31
  no shutdown
!
interface Loopback0.0
  ip address 10.0.12.100/24

peer-group で My-Home という名前を付けて as 65010 のルータを括ります。
ここに next-hop-self を書くいても効いていないようなのですが、ルーティングテーブルに載せるときに良きに計らってくれるようです。
route-map で in-comming を定義して、BGP で入ってきた経路の metric を 10 にしています。(ルータの向こう側へ行くときにコストが追加されるように) できれば 10 加算するとかできると複数台経由してもコストが計算できて良い気がするのですが、できないみたい。

RT-13
router bgp 65010
  neighbor 100.64.0.2 remote-as 65010
  neighbor 100.64.0.7 remote-as 65010
  neighbor 100.64.0.8 remote-as 65010
  address-family ipv4 unicast
    network 10.0.13.0/24
    network 100.64.0.2/31
    network 100.64.0.6/31
    network 100.64.0.8/31
!
interface GigaEthernet0.0
  ip address 100.64.0.3/31
  no shutdown
!
interface GigaEthernet1.0
  ip address 100.64.0.6/31
  no shutdown
!
interface GigaEthernet2.0
  ip address 100.64.0.9/31
  no shutdown
!
interface Loopback0.0
  ip address 10.0.13.100/24
RT-14
router bgp 65010
  neighbor 100.64.0.4 remote-as 65010
  neighbor 100.64.0.6 remote-as 65010
  address-family ipv4 unicast
    network 10.0.14.0/24
    network 100.64.0.4/31
    network 100.64.0.6/31
!
interface GigaEthernet0.0
  ip address 100.64.0.5/31
  no shutdown
!
interface GigaEthernet1.0
  ip address 100.64.0.7/31
  no shutdown
!
interface Loopback0.0
  ip address 10.0.14.100/24
RT-11
RT-11(config)# show ip route
IP Routing Table - 9 entries, 3 hidden, 2036 frees
Entries: 3 Connected, 0 Static, 0 RIP, 0 OSPF, 6 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     10.0.0.0/8 is subnetted, 4 subnets
C      10.0.11.0/24 [0/0] is directly connected, Loopback0.0, 0:12:05
B      10.0.12.0/24 [200/0] via 100.64.0.1, GigaEthernet0.0, 0:24:13
B      10.0.13.0/24 [200/10] via 100.64.0.1, GigaEthernet0.0, 0:24:13
B      10.0.14.0/24 [200/10] via 100.64.0.1, GigaEthernet0.0, 0:24:13
     100.0.0.0/8 is subnetted, 5 subnets
C      100.64.0.0/31 [0/0] is directly connected, GigaEthernet0.0, 2:05:55
C      100.64.0.2/31 [0/0] is directly connected, GigaEthernet1.0, 2:05:55
B      100.64.0.4/31 [200/0] via 100.64.0.1, GigaEthernet0.0, 0:24:14
B      100.64.0.6/31 [200/10] via 100.64.0.1, GigaEthernet0.0, 0:24:13
B      100.64.0.8/31 [200/0] via 100.64.0.1, GigaEthernet0.0, 0:24:14
RT-11(config)# ping 10.0.11.100 count 2
PING 10.0.11.100 > 10.0.11.100 56 data bytes
64 bytes from 10.0.11.100: icmp_seq=0 ttl=64 time=0.023 ms
64 bytes from 10.0.11.100: icmp_seq=1 ttl=64 time=0.017 ms

--- 10.0.11.100 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0.017/0.020/0.023
RT-11(config)# ping 10.0.12.100 count 2
PING 100.64.0.0 > 10.0.12.100 56 data bytes
64 bytes from 10.0.12.100: icmp_seq=0 ttl=64 time=0.093 ms
64 bytes from 10.0.12.100: icmp_seq=1 ttl=64 time=0.082 ms

--- 10.0.12.100 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0.082/0.087/0.093
RT-11(config)# ping 10.0.13.100 count 2
PING 100.64.0.0 > 10.0.13.100 56 data bytes
64 bytes from 10.0.13.100: icmp_seq=0 ttl=64 time=0.131 ms
64 bytes from 10.0.13.100: icmp_seq=1 ttl=64 time=0.108 ms

--- 10.0.13.100 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0.108/0.119/0.131
RT-11(config)# ping 10.0.14.100 count 2
PING 100.64.0.0 > 10.0.14.100 56 data bytes
64 bytes from 10.0.14.100: icmp_seq=0 ttl=63 time=0.144 ms
64 bytes from 10.0.14.100: icmp_seq=1 ttl=63 time=0.112 ms

--- 10.0.14.100 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0.112/0.128/0.144
RT-11(config)#
RT-11(config)# traceroute 10.0.14.100 source 10.0.11.100
TRACEROUTE 10.0.14.100 56 data bytes
 1 100.64.0.1 0 ms 0 ms 0 ms
 2 10.0.14.100 0 ms 0 ms 0 ms
RT-11(config)#
RT-14
RT-14(config)# show ip route
IP Routing Table - 9 entries, 3 hidden, 2036 frees
Entries: 3 Connected, 0 Static, 0 RIP, 0 OSPF, 6 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     10.0.0.0/8 is subnetted, 4 subnets
B      10.0.11.0/24 [200/10] via 100.64.0.4, GigaEthernet0.0, 0:06:35
B      10.0.12.0/24 [200/0] via 100.64.0.4, GigaEthernet0.0, 0:18:46
B      10.0.13.0/24 [200/10] via 100.64.0.4, GigaEthernet0.0, 0:18:45
C      10.0.14.0/24 [0/0] is directly connected, Loopback0.0, 2:00:32
     100.0.0.0/8 is subnetted, 5 subnets
B      100.64.0.0/31 [200/0] via 100.64.0.4, GigaEthernet0.0, 0:18:46
B      100.64.0.2/31 [200/10] via 100.64.0.4, GigaEthernet0.0, 0:18:46
C      100.64.0.4/31 [0/0] is directly connected, GigaEthernet0.0, 0:59:45
C      100.64.0.6/31 [0/0] is directly connected, GigaEthernet1.0, 2:00:15
B      100.64.0.8/31 [200/0] via 100.64.0.4, GigaEthernet0.0, 0:18:46
RT-14(config)#
RT-14(config)# traceroute 10.0.11.100 source 10.0.14.100
TRACEROUTE 10.0.11.100 56 data bytes
 1 100.64.0.4 0 ms 0 ms 0 ms
 2 10.0.11.100 0 ms 0 ms 0 ms
RT-14(config)# traceroute 10.0.12.100 source 10.0.14.100
TRACEROUTE 10.0.12.100 56 data bytes
 1 10.0.12.100 0 ms 0 ms 0 ms
RT-14(config)# traceroute 10.0.13.100 source 10.0.14.100
TRACEROUTE 10.0.13.100 56 data bytes
 1 100.64.0.4 0 ms 0 ms 0 ms
 2 10.0.13.100 0 ms 0 ms 0 ms
RT-14(config)#

状態をいろいろと。

RT-12
RT-12(config)# show ip bgp summary
BGP router ID 10.0.12.100, local AS number 65010
Cluster ID 10.0.12.100(167775332)
1 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.0.0      4    65010 11      12      0:07:45       ESTABLISHED
 100.64.0.5      4    65010 10      13      0:07:45       ESTABLISHED
 100.64.0.9      4    65010 10      13      0:07:46       ESTABLISHED

Total number of neighbors 3
RT-12(config)#
RT-12(config)# show ip bgp neighbors 100.64.0.5 advertised-routes
BGP table version is 10, local router ID is 10.0.12.100
Local AS number 65010, local cluster ID is 10.0.12.100(167775332)
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
*> 10.0.12.0/24       100.64.0.4               0        100  i
*>i10.0.13.0/24       100.64.0.9              10        100  i
*> 100.64.0.0/31      100.64.0.4               0        100  i
*>i100.64.0.2/31      100.64.0.0              10        100  i
*> 100.64.0.4/31      100.64.0.4               0        100  i
*>i100.64.0.6/31      100.64.0.9              10        100  i
*> 100.64.0.8/31      100.64.0.4               0        100  i

Total number of prefixes 7
RT-12(config)# show ip bgp neighbors 100.64.0.0 received-routes
BGP table version is 10, local router ID is 10.0.12.100
Local AS number 65010, local cluster ID is 10.0.12.100(167775332)
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
* i100.64.0.0/31      100.64.0.0              10        100  i
*>i100.64.0.2/31      100.64.0.0              10        100  i

Total number of prefixes 2
RT-12(config)# show ip bgp neighbors 100.64.0.0 advertised-routes
BGP table version is 10, local router ID is 10.0.12.100
Local AS number 65010, local cluster ID is 10.0.12.100(167775332)
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
*> 10.0.12.0/24       100.64.0.1               0        100  i
*>i10.0.13.0/24       100.64.0.9              10        100  i
*>i10.0.14.0/24       100.64.0.5              10        100  i
*> 100.64.0.0/31      100.64.0.1               0        100  i
*> 100.64.0.4/31      100.64.0.1               0        100  i
*>i100.64.0.6/31      100.64.0.9              10        100  i
*> 100.64.0.8/31      100.64.0.1               0        100  i

Total number of prefixes 7
RT-12(config)#
RT-12(config)# show ip route
IP Routing Table - 8 entries, 3 hidden, 2037 frees
Entries: 4 Connected, 0 Static, 0 RIP, 0 OSPF, 4 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     10.0.0.0/8 is subnetted, 3 subnets
C      10.0.12.0/24 [0/0] is directly connected, Loopback0.0, 1:50:15
B      10.0.13.0/24 [200/10] via 100.64.0.9, GigaEthernet2.0, 0:08:21
B      10.0.14.0/24 [200/10] via 100.64.0.5, GigaEthernet1.0, 0:08:21
     100.0.0.0/8 is subnetted, 5 subnets
C      100.64.0.0/31 [0/0] is directly connected, GigaEthernet0.0, 1:49:58
B      100.64.0.2/31 [200/10] via 100.64.0.0, GigaEthernet0.0, 0:08:21
C      100.64.0.4/31 [0/0] is directly connected, GigaEthernet1.0, 0:49:23
B      100.64.0.6/31 [200/10] via 100.64.0.9, GigaEthernet2.0, 0:08:22
C      100.64.0.8/31 [0/0] is directly connected, GigaEthernet2.0, 1:49:59
RT-14
RT-14(config)# show ip bgp summary
BGP router ID 10.0.14.100, local AS number 65010
1 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.0.4      4    65010 107     93      0:15:58       ESTABLISHED
 100.64.0.6      4    65010 93      95      0:59:27       ESTABLISHED

Total number of neighbors 2
RT-14(config)#
RT-14(config)# show ip bgp neighbors 100.64.0.4 received-routes
BGP table version is 55, local router ID is 10.0.14.100
Local AS number 65010
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
*>i10.0.11.0/24       100.64.0.0              10        100  i
*>i10.0.12.0/24       100.64.0.4               0        100  i
*>i10.0.13.0/24       100.64.0.9              10        100  i
*>i100.64.0.0/31      100.64.0.4               0        100  i
*>i100.64.0.2/31      100.64.0.0              10        100  i
* i100.64.0.4/31      100.64.0.4               0        100  i
* i100.64.0.6/31      100.64.0.9              10        100  i
*>i100.64.0.8/31      100.64.0.4               0        100  i

Total number of prefixes 8
RT-14(config)#
RT-14(config)# show ip bgp neighbors 100.64.0.4 advertised-routes
BGP table version is 55, local router ID is 10.0.14.100
Local AS number 65010
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
*> 10.0.14.0/24       100.64.0.5               0        100  i
*> 100.64.0.4/31      100.64.0.5               0        100  i
*> 100.64.0.6/31      100.64.0.5               0        100  i

Total number of prefixes 3
RT-14(config)#
RT-14(config)# show ip bgp neighbors 100.64.0.6 received-routes
BGP table version is 55, local router ID is 10.0.14.100
Local AS number 65010
Status codes: s - suppressed, * - valid, h - history, l - looped
              > - best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network            Next Hop            Metric     LocPrf  Path
* i10.0.13.0/24       100.64.0.6               0        100  i
* i100.64.0.2/31      100.64.0.6               0        100  i
* i100.64.0.6/31      100.64.0.6               0        100  i
* i100.64.0.8/31      100.64.0.6               0        100  i

Total number of prefixes 4
RT-14(config)#
RT-14(config)# show ip route
IP Routing Table - 9 entries, 3 hidden, 2036 frees
Entries: 3 Connected, 0 Static, 0 RIP, 0 OSPF, 6 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     10.0.0.0/8 is subnetted, 4 subnets
B      10.0.11.0/24 [200/10] via 100.64.0.4, GigaEthernet0.0, 0:06:35
B      10.0.12.0/24 [200/0] via 100.64.0.4, GigaEthernet0.0, 0:18:46
B      10.0.13.0/24 [200/10] via 100.64.0.4, GigaEthernet0.0, 0:18:45
C      10.0.14.0/24 [0/0] is directly connected, Loopback0.0, 2:00:32
     100.0.0.0/8 is subnetted, 5 subnets
B      100.64.0.0/31 [200/0] via 100.64.0.4, GigaEthernet0.0, 0:18:46
B      100.64.0.2/31 [200/10] via 100.64.0.4, GigaEthernet0.0, 0:18:46
C      100.64.0.4/31 [0/0] is directly connected, GigaEthernet0.0, 0:59:45
C      100.64.0.6/31 [0/0] is directly connected, GigaEthernet1.0, 2:00:15
B      100.64.0.8/31 [200/0] via 100.64.0.4, GigaEthernet0.0, 0:18:46
RT-14(config)#
RT-11
RT-11(config)# show ip bgp summary
BGP router ID 10.0.11.100, local AS number 65010
1 BGP AS-PATH entries

Neighbor         V    AS    MsgRcvd MsgSent Up/DownTime   State
 100.64.0.1      4    65010 103     94      0:12:28       ESTABLISHED
 100.64.0.3      4    65010 91      94      0:55:58       ESTABLISHED

Total number of neighbors 2
RT-11(config)#
RT-11(config)# show ip route
IP Routing Table - 9 entries, 3 hidden, 2036 frees
Entries: 3 Connected, 0 Static, 0 RIP, 0 OSPF, 6 BGP
Codes: C - Connected, S - Static, R - RIP, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, B - BGP
       * - Candidate default, s - Summary
Timers: Age
     10.0.0.0/8 is subnetted, 4 subnets
C      10.0.11.0/24 [0/0] is directly connected, Loopback0.0, 0:00:39
B      10.0.12.0/24 [200/0] via 100.64.0.1, GigaEthernet0.0, 0:12:47
B      10.0.13.0/24 [200/10] via 100.64.0.1, GigaEthernet0.0, 0:12:47
B      10.0.14.0/24 [200/10] via 100.64.0.1, GigaEthernet0.0, 0:12:47
     100.0.0.0/8 is subnetted, 5 subnets
C      100.64.0.0/31 [0/0] is directly connected, GigaEthernet0.0, 1:54:29
C      100.64.0.2/31 [0/0] is directly connected, GigaEthernet1.0, 1:54:29
B      100.64.0.4/31 [200/0] via 100.64.0.1, GigaEthernet0.0, 0:12:48
B      100.64.0.6/31 [200/10] via 100.64.0.1, GigaEthernet0.0, 0:12:47
B      100.64.0.8/31 [200/0] via 100.64.0.1, GigaEthernet0.0, 0:12:48
RT-11(config)#

本番環境であれば RT-12 が壊れると終わりなので、RT-13 もルートリフレクタにして RT-12 とクラスタを組む必要があるらしい。

1
1
0

Register as a new user and use Qiita more conveniently

  1. You get articles that match your needs
  2. You can efficiently read back useful information
  3. You can use dark theme
What you can do with signing up
1
1

Delete article

Deleted articles cannot be recovered.

Draft of this article would be also deleted.

Are you sure you want to delete this article?