1
1

Delete article

Deleted articles cannot be recovered.

Draft of this article would be also deleted.

Are you sure you want to delete this article?

More than 3 years have passed since last update.

第15回 DHCP機能

Last updated at Posted at 2021-01-30

##DHCP技術
IPアドレスをPCに割り当てる際、専用のサーバーを使用せずにルーターやL3スイッチでも同等の機能を使用することができる。大規模ネットワークではあまり使用されないが、支店やオフィスの会議室など小さな規模のネットワーク帯ではよく使用される。

##L3スイッチで各部署ごとに異なるアドレスを割り当て
構築ネットワーク
L3スイッチ DHCP.JPG

###投入コンフィグ(1個のルータでDHCPプール設定)

Router設定
enable secret TEST
!
username TEST secret TEST
!
ip dhcp excluded-address 192.168.1.1 192.168.1.10
※営業部のPCには110以外のIPアドレスを払い出す
ip dhcp excluded-address 10.1.4.1 10.1.4.40
※経理部のPCには140以外のIPアドレスを払い出す
!
ip dhcp pool TEST01
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip dhcp pool TEST02
network 10.1.4.2 255.255.252.0
default-router 10.1.4.3
dns-server 8.8.8.8
!
interface GigabitEthernet0/1
 no switchport
 ip address 10.1.4.5 255.255.252.0
 no shutdown
!
interface GigabitEthernet0/2
 no switchport
 ip address 192.168.1.1 255.255.255.0
 no shutdown
!

##複数ルーターでのDHCPリレー

###DHCPのリレー機能
ルータやDHCPサーバーでDHCP機能を設定した場合、L2スイッチならブロードキャストを通過させ、その先に接続されているPCに設定した範囲のIPアドレスを割り振ることはできる。
しかし、異なったネットワーク帯をつなぐルーター同士ではブロードキャストを通過せることは出来ない。そういう時に使用する機能がDHCPリレーエージェント機能

構築ネットワーク
リレーエージェント.JPG

###投入コンフィグ(DHCPリレーエージェント機能)

DHCPサーバー設定
!
ip dhcp excluded-address 192.168.1.1 192.168.1.10
ip dhcp excluded-address 172.16.1.1 172.16.1.10
ip dhcp excluded-address 162.15.14.1 162.15.14.10
!
ip dhcp pool Accounting
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 8.8.8.8
!
ip dhcp pool Sales1
 network 172.16.1.0 255.255.255.0
 default-router 172.16.1.1
 dns-server 8.8.8.8
!
ip dhcp pool Sales2
 network 162.15.0.0 255.255.240.0
 default-router 162.15.14.1
 dns-server 8.8.8.8
!
interface GigabitEthernet0/0
 ip address 10.1.1.1 255.255.255.252
no shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.1.1 255.255.255.0
no shutdown
!
ip route 172.16.1.0 255.255.255.0 10.1.1.2 
ip route 162.15.0.0 255.255.240.0 10.1.1.2 
!
DHCPリレー設定
!
interface GigabitEthernet0/0
 ip address 10.1.1.2 255.255.255.252
no shutdown
!
interface GigabitEthernet0/1
 ip address 172.16.1.1 255.255.255.0
 ip helper-address 10.1.1.1
no shutdown
!
interface GigabitEthernet0/2
 ip address 162.15.14.2 255.255.240.0
 ip helper-address 10.1.1.1
no shutdown
!
ip route 192.168.1.0 255.255.255.0 10.1.1.1 
!

#参考
[ネットワークエンジニアとして TCP/IP - DHCP]
(https://www.infraexpert.com/study/tcpip13.html)

1
1
0

Register as a new user and use Qiita more conveniently

  1. You get articles that match your needs
  2. You can efficiently read back useful information
  3. You can use dark theme
What you can do with signing up
1
1

Delete article

Deleted articles cannot be recovered.

Draft of this article would be also deleted.

Are you sure you want to delete this article?