0
0

Delete article

Deleted articles cannot be recovered.

Draft of this article would be also deleted.

Are you sure you want to delete this article?

第24回 Cisco CMLでスパイン & リーフ構成を構築

Last updated at Posted at 2025-05-10

データセンター環境でのネットワーク機器

 AIの需要拡大に伴い、通信量も劇的に増加した結果、近年データセンターの増設が頻繁に行われるようになっています。このデータセンター環境でよく利用されているCiscoの機器がNexusシリーズです。
 このNexus機器は、これまでの記事で書いてきたCiscoのIOS、IOS XE対応機器とはOSも全く異なるため使用できる技術も独自のものが多くあります。
 今回はこのNexus機器で小規模のスパイン & リーフ構成をCisco CMLで構築し検証を行いました。

スパイン & リーフ構成とは

image.png
 今まではコンフィグで制御していたネットワークに比べ柔軟性やスピードにも対応した現在主流のデータセンターのネットワーク構成です。
 従来のネットワークは3階層で構成されておりましたが、スパイン、リーフの2階層にすることでホップ数を減らし通信効率の向上が可能。
 また、APICと呼ばれる管理コントローラーのGUI画面から設定や制御ができます。

検証構成図

image.png

・LeafとSpineはNexus-OS 9000を使用
・SWはIOS-OSを使用

LeafとSpineをもう少し増設して検証したかったのですが、PCスペックの都合で今回はこの台数で環境を構築して検証を行いました。この機会にまたPC買いなおそうかな

検証項目

各SWから対向SWのインターフェースに設定されたIPアドレスに向けてping疎通を行う
EVPN-VXLANをLeaf1⇔Spine⇔Leaf2で構成しVXLANトンネルを作成する
③各Leafスイッチが対向Leafスイッチの下につながっているスイッチのMACアドレスを学習する

VXLAN

L3ネットワーク上でL2ネットワーク延伸を実現する技術。
今回の構成では、Leaf1⇔Spine⇔Leaf2の間をL3ネットワークのiBGPで構成し、その上にL2ネットワークを構築しています。

検証結果

①各SWから対向SWのインターフェースに設定されたIPアドレスに向けてping疎通成功

image.png

②Leaf1⇔Leaf2間でVXLANトンネルが確立

image.png

③各Leafスイッチで対向SWのMACアドレスの学習を確認

image.png
VXLANを経由して学習したMACアドレスはBGPから受け取っている。

投入コンフィグ

SW
SW1
interface GigabitEthernet0/0
 no switchport
 mac-address 0000.1111.1111
 ip address 192.168.10.11 255.255.255.0

interface GigabitEthernet0/1
 no switchport
 mac-address 0000.1111.2992
 ip address 192.168.11.81 255.255.255.0
end

SW2
interface GigabitEthernet0/0
 no switchport
 mac-address 0000.2222.2222
 ip address 192.168.10.22 255.255.255.0

interface GigabitEthernet0/1
 no switchport
 mac-address 0000.2222.3773
 ip address 192.168.11.92 255.255.255.0
end
Leaf1
interface loopback0
  ip address 172.16.255.2/32

interface loopback1
  ip address 172.16.254.1/32
  
interface Ethernet1/1
  no switchport
  ip address 172.16.13.3/24
  no shutdown

interface Ethernet1/2
  switchport
  switchport access vlan 120
  no shutdown

interface Ethernet1/3
  switchport
  switchport access vlan 140
  no shutdown

feature ospf

router ospf 1
  router-id 172.16.255.2
  
interface loopback0
  ip router ospf 1 area 0.0.0.0  

interface loopback1  
  ip router ospf 1 area 0.0.0.0

interface Ethernet1/1
  ip ospf network point-to-point
  ip router ospf 1 area 0.0.0.0

feature bgp
nv overlay evpn

router bgp 65005
  neighbor 172.16.255.1
    remote-as 65005
    update-source loopback0
    address-family l2vpn evpn
      send-community both

feature vn-segment-vlan-based
feature nv overlay

vlan 120
  vn-segment 10120
  
vlan 140
  vn-segment 10140

evpn
  vni 10120 l2
    rd auto
    route-target import auto
    route-target export auto  

  vni 10140 l2
    rd auto
    route-target import auto
    route-target export auto

interface nve1
  no shutdown
  host-reachability protocol bgp
  source-interface loopback1
  member vni 10120
    ingress-replication protocol bgp

  member vni 10140
    ingress-replication protocol bgp

Leaf2
interface loopback0
  ip address 172.16.255.3/32

interface loopback1
  ip address 172.16.254.2/32
  
interface Ethernet1/1
  no switchport
  ip address 172.16.14.4/24
  no shutdown

interface Ethernet1/2
  switchport
  switchport access vlan 120
  no shutdown

interface Ethernet1/3
  switchport
  switchport access vlan 140
  no shutdown

feature ospf

router ospf 1
  router-id 172.16.255.3
  
interface loopback0
  ip router ospf 1 area 0.0.0.0  

interface loopback1  
  ip router ospf 1 area 0.0.0.0

interface Ethernet1/1
  ip ospf network point-to-point
  ip router ospf 1 area 0.0.0.0

feature bgp
nv overlay evpn

router bgp 65005
  neighbor 172.16.255.1
    remote-as 65005
    update-source loopback0
    address-family l2vpn evpn
      send-community both

feature vn-segment-vlan-based
feature nv overlay

vlan 120
  vn-segment 10120
  
vlan 140
  vn-segment 10140

evpn
  vni 10120 l2
    rd auto
    route-target import auto
    route-target export auto  

  vni 10140 l2
    rd auto
    route-target import auto
    route-target export auto

interface nve1
  no shutdown
  host-reachability protocol bgp
  source-interface loopback1
  member vni 10120
    ingress-replication protocol bgp

  member vni 10140
    ingress-replication protocol bgp
Spine
interface loopback0
  ip address 172.16.255.1/32

interface Ethernet1/1
  no switchport
  ip address 172.16.13.1/24
  no shutdown

interface Ethernet1/2
  no switchport
  ip address 172.16.14.1/24
  no shutdown 

feature ospf

router ospf 1
  router-id 172.16.255.1
  
interface loopback0
  ip router ospf 1 area 0.0.0.0  
  
interface Ethernet1/1
  ip ospf network point-to-point
  ip router ospf 1 area 0.0.0.0

interface Ethernet1/2
  ip ospf network point-to-point
  ip router ospf 1 area 0.0.0.0

feature bgp
nv overlay evpn

router bgp 65005
  neighbor 172.16.255.2
    remote-as 65005
    update-source loopback0
    address-family l2vpn evpn
      send-community both
      route-reflector-client
      
  neighbor 172.16.255.3
    remote-as 65005
    update-source loopback0
    address-family l2vpn evpn
      send-community both
      route-reflector-client

参考

次回

オーバーレイネットワーク、アンダーレイネットワークに関して記事を作成予定

0
0
0

Register as a new user and use Qiita more conveniently

  1. You get articles that match your needs
  2. You can efficiently read back useful information
  3. You can use dark theme
What you can do with signing up
0
0

Delete article

Deleted articles cannot be recovered.

Draft of this article would be also deleted.

Are you sure you want to delete this article?