Help us understand the problem. What is going on with this article?

【CCNA】VLANとシスココマンドについてまとめてみた

VLAN

スイッチでネットワークを分割する機能、ブロードキャストドメインの分割をレイヤ2レベルで実現することができる。それぞれ一つのサブネットに対応。

セキュリティ的メリット

  • トラフィックをL2レベルで分離できるので異なるVLANへのアクセスができない

トランクプロトコル

イーサネットフレームヘッダにVLANタグ情報を挿入する規約

  • IEEE 802.Q 標準プロトコルで主流。異なるベンダでもトランク接続できる
  • ISL はシスコ独自

IEEE802.1Q

イーサネットフレームヘッダにVLANタグ情報を挿入する。

ネイティブVLAN

  • イーサネットフレームヘッダにVLANタグ情報がないもの
  • VLAN1と認識される。VLAN1は管理VLAN

VLAN間ルーティング

サブインタフェース

ルータのインターフェースに論理的なインターフェースをつけること

Router on Stick

サブインタフェースの作成
トランクの設定
IPアドレスの割当

L3スイッチを使用したVLAN間ルーティング

L2スイッチ、ルータを使用せずにL3一つでVLAN間ルーティング可能

SVI

VLANが内部ルータと接続するための仮想的なインターフェース

DTP

動的なトランクの設定

対向機器のポートとネゴシエーションを行いその設定に応じてアクセス・トランクポートとトランクプロトコルを(IEEE802.1Q/ISL)動的に切り替えるためのシスコ独自のプロトコル

  • dynamic desirable 対向とネゴシエーションを行いトランクになろうとする。ネゴシエーションして対向ポートの設定モードが trunk、desirable、auto ならばポートはトランクポートになり、access ならばアクセスポートになります。
  • dynamic auto 対向ポートからトランクになるように働きかけられるとトランクになる。対向ポートの設定モードが trunk または desirable ならばポートはトランクポートになり、それ以外ならアクセスポートになります。
  • on トランクモード
  • off アクセスモード

静的なトランクの設定

switchport trunk encapsulation isl|dot1q|negotiate(デフォ)
switchport mode trunk
switchport nonegotiate DTPの停止

switchport trunk encapsulation
Catalyst2960等、dot1qだけサポートしており、コマンド自体が使えないスイッチもあります。

VTP

トランクポートからVTPアドバタイズメントと呼ばれるメッセージを送信して、スイッチネットワーク全体で設定されているVLAN情報の同期をとるシスコ独自のプロトコル。

vtp mode transparent
vtp mode off

vlan設定で使うコマンド

設定

端末がつながっているポートをスイッチポートに設定

  • (config)vlan 10 // vlan 1-10,15,25 でまとめて作れる
  • (config-vlan)exit //VLAN作成を完了 
  • (config)int fa0/1
  • (config-if)switchport mode access
  • (config-if)switchport access vlan 10
  • (config-if)end

vlanの確認

  • show vlan brief
  • show int status

トランクポート

DTP

対向機器のポートとネゴシエーションを行い、その設定に応じてスイッチポートのタイプ(トランク/アクセス)及びトランクプロトコルを(IEEE802.1Q/ISL)を動的に切り替えるために開発されたシスコ独自のプロトコル

動的トランクポートの設定

  • int fa0/1
  • switchport mode dynamic desirable | auto

静的に設定(たぶんこっちをよく使いそう)

  • int fa0/1
  • switchport mode trunk encapsulation dot1q
  • switchport mode trunk
  • switchport nonegotiate //dtpを無効化

確認

  • show int trunk

Vlan間ルーティング

異なるVLANに所属するホスト間の通信にはルーティングデバイスが必要。
ルータL3スイッチを使ってVLAN間ルーティングを行う

ルータ(Router on a stick)

//一つ目のサブインタフェース
* int fa0/1.1 //サブインタフェース番号2で作成
* Router(config-subif)# encapsulation dot1q 1 // 802.1Qとvlan1を指定
* ip address 192.168.0.1 // vlan1のGW
* exit
//2つ目のサブインタフェース
* int fa0/1.10
* encapsulation dot1q 10
* ip address 192.168.0.10 //vlan10のGW
* exit
* int fa0/1
* no shutdown

L3スイッチを用いたVLAN間ルーティング

L3スイッチが持つ内部の仮想ルータのIFをSVIという。SVIにIPアドレスを設定する。VLANごとにSVIを作成してIPアドレスを設定。

スイッチとの接続をトランクモードに設定

  • int fa0/1
  • switchport mode trunk encapsulation dot1q
  • switchport mode trunk
  • switchport nonegotiate //dtpを無効化

ルーティング設定

  • ip routing
  • int vlan 1 // SVI1の設定
  • ip address 192.168.0.1 255.255.255.0 //VLAN1のGW
  • no shutdown //SVIを有効化

Cisco ios

シスコのほとんどのルータとスイッチで使用されているOS。

iosのモード

  • EXEC(ユーザーEXEC)
    • 設定のモニタリングモード。接続したときの最初のモード。
    • Switch>
  • 特権EXECモード
    • enableコマンド
    • Switch#
    • すべての設定情報を見ることができる

コンフィグレーションモード

  • グローバルコンフィグレーションモード
    • デバイス全体に関わる設定
    • configure terminal (conf t)
    • 設定した内容を確認するには特権Execモードに戻る必要がある。

管理用IPの設定

* interface vlan vlan1
* ip address 192.168.0.10 255.255.255.0
* no shutdown (インタフェイスの有効化。vlan1はデフォで無効化されている)
* exit
* ip default-gateway 192.168.0.1

その他コマンドなど

show running-config

スイッチポートの詳細

  • show interfaces fastethernet 0/3
  • show int fa0/3

すべてのポートの要約

  • show interface status
Why do not you register as a user and use Qiita more conveniently?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
Comments
Sign up for free and join this conversation.
If you already have a Qiita account
Why do not you register as a user and use Qiita more conveniently?
You need to log in to use this function. Qiita can be used more conveniently after logging in.
You seem to be reading articles frequently this month. Qiita can be used more conveniently after logging in.
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away