Qiita Teams that are logged in
You are not logged in to any team

Log in to Qiita Team
Community
OrganizationAdvent CalendarQiitadon (β)
Service
Qiita JobsQiita ZineQiita Blog
2
Help us understand the problem. What is going on with this article?
@atsuto

ROSインストール Ubuntu対応バージョン

Ubuntuバージョン Ubuntuコードネーム ROS1バージョン
Ubuntu 20.10 Groovy Gorilla ※ インストールできない
Ubuntu 20.04 Focal Fossa ROS Noetic Ninjemys
Ubuntu 18.04 Bionic Beaver ROS Melodic Morenia
Ubuntu 17.04 Zesty Zapus ROS Lunar Loggerhead
Ubuntu 16.04 Xenial Xerus ROS Kinetic Kame

※ROSの古いバージョンでGroovyという同じ名前があるので要注意。

Ubuntu20.10へROS Noeticをインストールしてみる

20.10 Groovy Gorilla

E: The repository 'http://packages.ros.org/ros/ubuntu groovy Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

普通にインストールしようとするとエラー。

http://packages.ros.org/ros/ubuntu/dists/focal/
ここを見てみると、Focalしかない。
下記でgroovyから、focalに書き換えてしまう。

$ sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu focal main" > /etc/apt/sources.list.d/ros-latest.list'

apt updateはできるようになったが、

$ sudo apt install ros-noetic-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gazebo11 : Depends: libboost-regex1.71.0-icu66 but it is not installable
            Depends: libignition-msgs5 (>= 5.3.0) but it is not going to be installed
            Depends: libignition-transport8 (>= 8.0.0) but it is not going to be installed
            Depends: libprotobuf17 but it is not installable
 gazebo11-common : Depends: ttf-dejavu-core but it is not installable
 gazebo11-plugin-base : Depends: libignition-msgs5 (>= 5.3.0) but it is not going to be installed
                        Depends: libignition-transport8 (>= 8.0.0) but it is not going to be installed
                        Depends: libprotobuf17 but it is not installable
 libgazebo11 : Depends: libboost-regex1.71.0-icu66 but it is not installable
               Depends: libgdal26 (>= 3.0.0) but it is not installable
               Depends: libignition-fuel-tools4 (>= 4.1.0) but it is not going to be installed
               Depends: libignition-msgs5 (>= 5.3.0) but it is not going to be installed
               Depends: libignition-transport8 (>= 8.0.0) but it is not going to be installed
               Depends: libprotobuf17 but it is not installable
               Depends: libtinyxml2-6a (>= 6.0.0) but it is not installable
 libignition-common3-av-dev : Depends: libignition-cmake2-dev but it is not installable
 libignition-common3-core-dev : Depends: libignition-cmake2-dev but it is not installable
 libignition-common3-events-dev : Depends: libignition-cmake2-dev but it is not installable
 libignition-common3-graphics-dev : Depends: libignition-cmake2-dev but it is not installable
                                    Depends: libignition-common3-graphics (= 3.6.0-1~focal) but it is not going to be installed
 libignition-common3-profiler-dev : Depends: libignition-cmake2-dev but it is not installable
 libignition-fuel-tools4-dev : Depends: libignition-cmake2-dev but it is not installable
                               Depends: libignition-fuel-tools4 (= 4.2.1-2~focal) but it is not going to be installed
 libignition-math6-dev : Depends: libignition-cmake2-dev but it is not installable
 libignition-msgs5-dev : Depends: libignition-cmake2-dev but it is not installable
                         Depends: libignition-msgs5 (= 5.3.0-1~focal) but it is not going to be installed
 libignition-transport8-core-dev : Depends: libignition-transport8 (= 8.1.0-1~focal) but it is not going to be installed
                                   Depends: libignition-cmake2-dev but it is not installable
 libignition-transport8-log-dev : Depends: libignition-cmake2-dev but it is not installable
                                  Depends: libignition-transport8-log (= 8.1.0-1~focal) but it is not going to be installed
 ros-noetic-class-loader : Depends: libpocofoundation62 (>= 1.9.2) but it is not installable
 ros-noetic-controller-manager : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-cv-bridge : Depends: libboost-regex1.71.0-icu66 but it is not installable
 ros-noetic-diagnostic-aggregator : Depends: libboost-regex1.71.0-icu66 but it is not installable
                                    Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-gazebo-plugins : Depends: libprotobuf17 but it is not installable
 ros-noetic-gazebo-ros : Depends: libprotobuf17 but it is not installable
 ros-noetic-gazebo-ros-control : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
                                 Depends: ros-noetic-transmission-interface but it is not going to be installed
 ros-noetic-image-transport : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-kdl-parser : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-laser-assembler : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-laser-filters : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-nodelet : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-pcl-ros : Depends: libpcl-common1.10 (>= 1.10.0+dfsg) but it is not installable
                      Depends: libpcl-features1.10 (>= 1.10.0+dfsg) but it is not installable
                      Depends: libpcl-filters1.10 (>= 1.10.0+dfsg) but it is not installable
                      Depends: libpcl-io1.10 (>= 1.10.0+dfsg) but it is not installable
                      Depends: libpcl-search1.10 (>= 1.10.0+dfsg) but it is not installable
                      Depends: libpcl-segmentation1.10 (>= 1.10.0+dfsg) but it is not installable
                      Depends: libpcl-surface1.10 (>= 1.10.0+dfsg) but it is not installable
 ros-noetic-pluginlib-tutorials : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-rosbag : Depends: libboost-regex1.71.0-icu66 but it is not installable
                     Depends: ros-noetic-rosbag-storage but it is not going to be installed
 ros-noetic-rosconsole : Depends: libboost-regex1.71.0-icu66 but it is not installable
 ros-noetic-rospack : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-rqt-gui-cpp : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
                          Depends: ros-noetic-qt-gui-cpp (>= 0.3.0) but it is not going to be installed
 ros-noetic-rviz : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
 ros-noetic-urdf : Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

エラーが出て、やっぱり難しそう。。

2
Help us understand the problem. What is going on with this article?
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
atsuto
自動運転車向けのシステムを作ってます。 ヤフー/ソフトバンク Webエンジニア iPhoneアプリ/ロボアプリ/自動運転車開発
boldly
自動運転車両運行プラットフォーム Dispatcherを開発・運用しています。

Comments

No comments
Sign up for free and join this conversation.
Sign Up
If you already have a Qiita account Login
2
Help us understand the problem. What is going on with this article?