Posted at

RC版のAndroidGradlePluginの指定方法

More than 3 years have passed since last update.

公式サイトの通り指定すれば、確かに一致するのですが紛らわしかったのでメモしておきます。

AndroidStudio 1.0のリリースに伴って、AndroidGradlePluginも1.0がリリースされました。(正確にはまだRC版ですが)

そのためAndroidStudioさんのlintチェックに従えば、以下のように書くことが推奨されてます。


build.gradle

buildscript {

repositories {
jcenter()
}
dependencies {
classpath 'com.android.tools.build:gradle:1.0.0'
}
}

ところが公式サイトのリリースノートを見ると、1.0.0-rcxというバージョンが複数リリースされてます。

これを直接指定したいなーと思って、以下のように書いてみました。


build.gradle

    dependencies {

classpath 'com.android.tools.build:gradle:1.0.0-rc4'
}

そうするとlintさんが、ちゃんと1.0.0って指定してくれとお怒りになるんですよね。赤いアンダーライン付きで。

mavenリポジトリ見てみればいいかと思い、見に行った結果がこれでした。

スクリーンショット 2014-12-18 11.22.54.png

現場からは以上です。