Vagrant

vagrant vbguestのプラグインインストールが失敗する

More than 1 year has passed since last update.


vagrant-vbguest のインストールに失敗した時の対処 覚書き


各種バージョン


  • VirtualBox 5.2.4

  • Vagrant 2.0.1

  • vagrant-vbguest 0.15.0


失敗したログ

$ VBoxManage -v

5.2.4r119785

$ Vagrant -v
Vagrant 2.0.1

$ vagrant plugin install vagrant-vbguest

Ignoring ffi-1.9.10 because its extensions are not built. Try: gem pristine ffi --version 1.9.10
Ignoring nokogiri-1.6.3.1 because its extensions are not built. Try: gem pristine nokogiri --version 1.6.3.1
Ignoring unf_ext-0.0.7.1 because its extensions are not built. Try: gem pristine unf_ext --version 0.0.7.1
Installing the 'vagrant-vbguest' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:
conflicting dependencies ffi (= 1.9.18) and ffi (= 1.9.10)
Activated ffi-1.9.10
which does not match conflicting dependency (= 1.9.18)
Conflicting dependency chains:
ffi (= 1.9.10), 1.9.10 activated
versus:
ffi (= 1.9.18)
Gems matching ffi (= 1.9.18):
ffi-1.9.18
$


回避方法

VAGRANT_DISABLE_STRICT_DEPENDENCY_ENFORCEMENT=1 vagrant plugin install vagrant-vbguest


成功したログ

$ VAGRANT_DISABLE_STRICT_DEPENDENCY_ENFORCEMENT=1 vagrant plugin install vagrant-vbguest

Ignoring ffi-1.9.10 because its extensions are not built. Try: gem pristine ffi --version 1.9.10
Ignoring nokogiri-1.6.3.1 because its extensions are not built. Try: gem pristine nokogiri --version 1.6.3.1
Ignoring unf_ext-0.0.7.1 because its extensions are not built. Try: gem pristine unf_ext --version 0.0.7.1
Installing the 'vagrant-vbguest' plugin. This can take a few minutes...
Fetching: vagrant-share-1.1.9.gem (100%)
Fetching: micromachine-2.0.0.gem (100%)
Fetching: vagrant-vbguest-0.15.0.gem (100%)
Installed the plugin 'vagrant-vbguest (0.15.0)'!
$