0
0

ccna取得に向けてCiscoPacketTracerで構築練習 ~Ether Channel~

Posted at

はじめに

CCNAを受験するにあたって、実際にコマンドを打って構築をすることが大切らしい。
Cisco Packet Tracerを使用して構築の練習とその流れ、結果を示して、気づいたことなどをまとめていこうと思う。

目標

  • L2 EtherChanneを設定する
  • L3 EtherChanneを設定する
  • それぞれ適切に動作するか確認する。

実践

1. L2 EtherChannel

channel1-1.png
デフォルトの状態だとSTPによって1つのリンクしか使えていない。

Switch0
Switch0(config)#interface range fa 0/22-24
Switch0(config-if-range)#switchport mode access
Switch0(config-if-range)#channel-group 1 mode on
Switch0(config-if-range)#
Creating a port-channel interface Port-channel 1

%LINK-5-CHANGED: Interface Port-channel1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
Switch0(config-if-range)#exit
Switch1
Switch1(config)#interface range fa 0/22-24
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#channel-group 1 mode on
Switch1(config-if-range)#
Creating a port-channel interface Port-channel 1

%LINK-5-CHANGED: Interface Port-channel1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

Switch1(config-if-range)#exit

今回はネゴシエーションはせず手動で設定した。

Cisco Packet Tracer 2024-05-25 22-44-27.gif

バンドルされたリンクが使用されており、Pingも通っている。

2. L3 EtherChannel

L3switchのルーテッドポートでもEtherChannelを設定する。
channel2-1.png

L3Switch0
//VLAN設定
L3Switch0(config)#interface vlan 10
L3Switch0(config-if)#ip address 192.168.1.254 255.255.255.0
L3Switch0(config-if)#no sh
L3Switch0(config-if)#exit
L3Switch0(config)#interface fa 0/1
L3Switch0(config-if)#switchport access vlan 10
L3Switch0(config-if)#switchport mode access 
L3Switch0(config-if)#exit
L3Switch0(config)#ip routing

//EtherChanne設定
L3Switch0(config)#interface range fa 0/23-24
L3Switch0(config-if-range)#no switchport 
L3Switch0(config-if-range)#channel-group 1 mode active
L3Switch0(config-if-range)#exit
L3Switch0(config)#interface Port-channel 1
L3Switch0(config-if)#ip address 192.168.10.1 255.255.255.0
L3Switch0(config-if)#exit

//スタティックルート
L3Switch0(config)#ip route 192.168.2.0 255.255.254.0 192.168.10.2
L3Switch0(config)#end

//LACP確認
L3Switch0#show etherchannel summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

1      Po1(RU)           LACP   Fa0/23(P) Fa0/24(P) 
L3Switch1
//VLAN設定
L3Switch1(config)#interface vlan 20
L3Switch1(config-if)#ip address 192.168.2.254 255.255.255.0
L3Switch1(config-if)#no sh
L3Switch1(config-if)#exit
L3Switch1(config)#interface vlan 30
L3Switch1(config-if)#ip address 192.168.3.254 255.255.255.0
L3Switch1(config-if)#no sh
L3Switch1(config-if)#exit
L3Switch1(config)#interface fa 0/1
L3Switch1(config-if)#switchport mode access
L3Switch1(config-if)#switchport access vlan 20
L3Switch1(config-if)#exit
L3Switch1(config)#interface fa 0/2
L3Switch1(config-if)#switchport mode access
L3Switch1(config-if)#switchport access vlan 30
L3Switch1(config-if)#exit
L3Switch1(config)#ip routing

//EtherChannel設定
L3Switch1(config)#interface range
L3Switch1(config)#interface range fa 0/23-24
L3Switch1(config-if-range)#no switchport 
L3Switch1(config-if-range)#channel-group 1 mode active
L3Switch1(config-if-range)#exit
L3Switch1(config)#interface Port-channel 1
L3Switch1(config-if)#ip address 192.168.10.2 255.255.255.0
L3Switch1(config-if)#exit

//スタティックルート
L3Switch1(config)#ip route 192.168.1.0 255.255.255.0 192.168.10.1
L3Switch1(config)#end

//LACP確認
L3Switch1#show etherchannel summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

1      Po1(RU)           LACP   Fa0/23(P) Fa0/24(P) 

Cisco Packet Tracer 2024-05-26 00-00-43.gif
Pingによる疎通確認ができた。

参考文献

0
0
0

Register as a new user and use Qiita more conveniently

  1. You get articles that match your needs
  2. You can efficiently read back useful information
  3. You can use dark theme
What you can do with signing up
0
0